Can I stop Obsidian from following symlinks in a folder it opens as a vault?

What I’m trying to do

I want to add Obsidian to an existing multi-year personal knowledge management workflow. The workflow involves year-based directories with text file notes. I tried to open the “Notes 2023” folder as a vault. The Obsidian app then hung. When I tried again, the vault opening failed with an error message in the app.

I believe the problem relates to an existing web of symbolic links in these year-based directories. Each directory has a symlink to the corresponding directory for the previous year, to the corresponding directory for the following year (but not the current year’s directory), and to the sister directory for another project for the same year. I have a couple years of these directories on my computer, then the symlinks jump to a file server where many years of older directories are located.

It appears that the Obsidian app unconditionally follows symlinks which it finds in the directory it is trying to open as a vault.

Note that the folder and vault in question are local to my computer. This is not any question of Sync being involved in this situation.

Question: Is there a way to use Obsidian to edit files in these year-based directories, while retaining the convenience of the symbolic links to sister directories and back to historical directories?

Things I have tried

I read the help article, Symbolic links and junctions. I am complying with one of its warnings, “Symlink targets must be fully disjoint from the vault root or any other symlink targets.” Other warnings are not applicable: those regarding Sync use, and symlinks in the .obsidian subdirectory.

macOS has security settings which permit or reject app access to local file system volumes, and to network volumes. The first time I tried opening this note directory as a vault, I granted the app access to local and network volumes. The result was a hang. I then told macOS to deny the app access to network volumes. When I tried again to open this directory as a vault, the result was that the app did not hang, but did display an error message about being unable to read a file path. It happened to be the target of a symlink. That target was on the network volume. Thus the OS security settings were apparently effective.

I made a copy of the current year’s notes directory, and deleted the symbolic links to the previous year and to the sister directory. I opened that directory as a vault. This succeeded, quickly and with no error.

As a workaround, I have made a separate Obsidian vault, as a temporary place to edit notes using Obsidian. I plan to move files from this vault to the year-based directory from time to time.

I made an Excluded Files pattern, in Settings – Files & Links – Excluded files, to exclude files with the name of the symbolic links. This was not effective. I suspect that Obsidian does not consult those patterns when opening symbolic links to directories.

I am running Obsidian for macOS 1.4.16 on macOS Monterey 12.7.2.