Can I have the Italic font setting please?

I noticed you can choose “Text font” in “Appearance”, and I want to choose the font “KaiTi” for Italic style within Markdown syntax *italic*.

Because I write in Chinese, we just do not have tilt characters. Using another font beside the normal text font is a better choice!

You should be able to use a CSS snippet for this. If you don’t need actual italics or matching text for the alphabet:

em, .cm-em {
    font-family: 'STKaiti';
    font-style: normal;  
}

In the note (forgive me if the Chinese is wrong :sweat_smile:):

一日之计在于晨。
A day's planning is done at dawn.

**一日之计在于晨。**
**A day's planning is done at dawn.**

*一日之计在于晨。*
*A day's planning is done at dawn.*

_一日之计在于晨。_
_A day's planning is done at dawn._


Or another version:

em, .cm-em {
    font-family: 'Inter', 'STKaiti';
    font-style: italic;  
}

1 Like

Hi, thank you for your reply! I’m aware of CSS rendering, but it dosen’t work as I miss the “.cm-em” part, strange. I prefer a simple setting, thank you anyway!

just to know because I didn’t what at css for a while.
em & .cm-em are for what exactly?

https://www.w3schools.com/tags/tag_em.asp

It’s for emphasized text, aka italic text. em takes care of reading view and rendered contexts, .cm-em is for source mode and live preview.