Calendar Plugin cut off in the middle regardless of pane size

What I’m trying to do

The Calendar plugin suddenly stopped showing up properly. I would like to fix it.

Things I have tried

In order, I tried:

  • resizing the pane
  • closing and opening the plugin
  • reloading Obsidian
  • reinstalling the plugin

I am really not sure what I did to cause this, but now I can’t figure out how to fix it. Help would be greatly appreciated. Thanks!

Your screenshot is zoomed is pretty far, so it’s hard to see where the calendar is in relation to side panel, main notes tab, etc. Maybe one from farther out could help?

If you switch to the default theme (if you are using a community theme), how does it look then?

This is what it looks like zoomed out some and in the default theme.

Huh. Now that’s a new one - I’ve never seen that before.

Try quitting Obsidian, moving the workspace.json file out of .obsidian/, and restarting. This will reset your window layout and hopefully sort out the calendar. :crossed_fingers: :crossed_fingers:

Wow, I thought that would do it. What have I done? :sob: I use Calendar all the time so I was really hopeful that would work.

It’s most likely another plugin mucking things up then(?). I’d try turning off some plugins (other than calendar), using the default theme, to see if helps.

You can put back your original workspace.json file if you want. Sorry about that :stuck_out_tongue:

I turned off CSS and tried turning off the plugins one at a time after I posted that first message, hoping I might still be able work it out myself, but no such luck. I also opened a Sandbox vault just to check it worked in there, and of course it did. I really am stuck. I’ll cycle through the plugins again and see if I can pinpoint one. If you have any other ideas, I’ll happily try them.

Oop, hang on I found it. It is the Pieces plugin. I am not sure why it is poking Calendar, but it is. Odd.

Yeah, no idea.

The troubleshooting tips are here: About the Bug reports category - #11 by system - pretty much what you are doing, but some plugins need a restart of Obsidian to fully quit. Turn off half → restart → no change… turn off the other half → restart, etc. to narrow it down. Good luck :muscle:

Thank you so much for your help. You are awesome! :grin:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.