Buttons (plugin) - inline buttons don't work in live preview

What I’m trying to do

I am trying to use inline buttons (using the buttons plug in). It seems that this was a problem in the past, but was fixed in a previous release Release Bugfix: Buttons render on obsidian load · shabegom/buttons · GitHub

Although the main README says that this is a “next version not released” GitHub - shabegom/buttons at 0.4.19 - it seems that the released version is 2 commits ahead of the fix.

Things I have tried

I have confirmed that I am running a version that is after the version where the fix is happening.

I have tried to locate contact information for the plugin author and the author of the fix.

I have found that the pull request for the fix was actually merged. Bug fix: render buttons in Live Preview mode when Obsidian starts by Lx · Pull Request #116 · shabegom/buttons · GitHub

I checked that the code from the pull request is actually in the main.js that I have.

I have confirmed that my buttons work fine outside of live preview mode.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.