Button to open local vault unavailable

Steps to reproduce

  • Have past Obsidian folder containing old vault folders in iCloud
  • Open a fresh installation of Obsidian on IPhone IOS 16.3.1.

Expected result

  • Expect to see a button allowing me to open a new vault that is locally on my device

Actual result

  • No button is available whereas it is on desktop—mobile app only provides buttons to sync, create a new vault, or open the past vaults from my iCloud

My reason for wanting to open the vault locally is to increase the speed of viewing my vault


  • Operating system: IOS 16.3.1

I don’t understand, you can open a vault in the Obsidian Iclould folder.

If the vault is somewhere else in icloud, it’s not a bug. it cannot be done.

Obsidian mobile doesn’t let me open a vault that is locally on my device ONLY on iCloud if I have used iCloud in the past. Whereas in Obsidian Desktop, you have the option to choose both. I would like to open a vault that is store ON my device not a vault that is in the cloud.

Obsidian only has access to
iCloud Drive/Obsidian and
On My iPhone(iPad)/Obsidian directories. That’s it.

To open/change vaults on iOS/iPadOS, click on your vault name. A list will show with iCloud vaults at the top and local vaults below.

Notice how, even in your drop-down menu from the image, only the iCloud options are available? The only other option is “Manage vaults…” and once clicked, it takes you to the main startup page which still doesn’t provide an option to select an On My Iphone vault.

Local vaults you already created are below. I just omitted them from the screenshot.

To create a local vault, bottom of that list, tap Manage vaults...

Create new vault and give it a name.

It will then be in that list.

So opening a vault that has been copy and pasted locally (on my iPhone & not in iCloud) is not yet supported on mobile?

I am trying to open a vault that was previously created elsewhere and has been copied into my local directory. This is not an available option to open and needs to be added to Obsidian mobile. Your work-around forces me to create a vault to store locally and not open a vault that has been copied onto my iPhone…

Using the iOS Files app, I coped “ATESTVAULT” from iCloud Drive/Obsidian to On My iPhone/Obsidian, restarted Obsidian, it showed up in the list and opens fine.

If the vault is intact and in the On My iPhone/Obsidian directory, it will show up in this vault picker and the “Manage vaults” list. I don’t know what else to say.

I see… So I need to create another Obsidian directory inside of On My iPhone. That might be the missing link. I will mark this as the solution after I verify this solved my problem. Thanks!

This still didn’t seem to work on IOS 16.4. Even after creating the Obsidian directory and adding my copied vault, Obsidian mobile still couldn’t locate the On My iPhone directory. I even tried closing the app and reopening. Also turning my device on & off.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.