Button (plugin) not disappearing once clicked

What I’m trying to do

I have been experimenting with a button in my daily template that calls another template via templater which then asks a few questions with the system command and logs the result at the top of the note. I initially set the button to disappear once it had been clicked, and it was working… and now it isn’t. By which I mean it’s inserting the template correctly, it’s just not deleting itself.

I can’t work out if this is something I have done or not. I don’t think I changed anything between when it worked and when it didn’t, but feel I must have done.

Any pointers? Thanks

Things I have tried

I tried creating a new empty note, recreating the button in there and the same issue persists.

Could you show some code for the button definitions at least? It’s hard to tell if there is any issues with your code, when we have to guess what you’ve written! :smiley:

Sure! I should have thought of that.

I am using the Button Maker to make them.

This is the resulting code

name Test Me!
type append text
action Done.


For the purposes of making this screenshot and grabbing the code just now I made a new note and used Button Maker to insert just one button. I’ve clicked it, and it’s added the text to the note as expected but is still there.

Just now I tried manually specifying the button that should be removed

remove j0hv

but it makes no difference.

Probably related issues on github:

The button maker is not adding the remove property to the code. If you add a line remove true to the code, it will work. I tried this and it worked for me

name Test
type append text
action Done!
color blue
remove true

Thanks for the reply.

But I have tried this and it’s not working for me. I also tried using the button ID.

What I find most odd is when I first installed it earlier in the day it was working as expected, I remember because it was getting a bit annoying when testing to have to keep re-adding the button :slight_smile:

I am experiencing the same issue… my button code is:

name Insert Summary
type append template
action summary
remove true

And my “summary” template is added as desired, but the button remains despite my manually adding “remove true” to the code.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.