Bullet spacing is inconsistent in reading mode

What I’m trying to do

When I start writing a bulleted list and then switch to reading mode, what I expect is that there will be a single line break in between each bullet. But there’s a subtle behaviour where sometimes all of the bullets in the note will be displayed with two line breaks between them, even if that’s not how you’ve formatted it.

Steps to reproduce:

  • Set strict line breaks to “true”
  • Open a new note in Obsidian
  • Create a bullet point list with two or more items, with only one line break between them
  • Press Enter
  • Create another bullet point list with one or more items, with one line break between them
  • Switch to Reading mode
  • All bullets are displayed with two line breaks between them.

However, the problem disappears if I remove the extra line break - i.e. if it’s one long list.

Things I have tried

I’ve tried changing Settings > Display > Strict Line Breaks from on to off, but can’t seem to change the behaviour.

It’s minor, but it breaks up the flow of my notes when I have a lot of bulleted lists. Is there any fix or is it just a known bug?

(Side note, is there a reason why “What I’m trying to do” and “What I’ve tried” prompts in the forum posts are inverted? Seems logically like it would be the other way around!)

Interestingly this problem disappears if you insert any kind of break in between the bulleted lists, such as a heading, a line break or other text:

However additional line breaks on their own seem to make no difference:

This is not a bug. Search markdown loose lists.