Bugged inconsistent space indentation

Steps to reproduce

  • Turn off the Tab Indentation and set Indentation size to 4
  • Create a list item, then add an indented child

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

For indentation to be 4 whitespaces, same as it is when indentation set to different values

Actual result

Actual indentation becomes “4 white space characters + a tab-sized gap that isn’t a character”

Environment

SYSTEM INFO:
	Obsidian version: v1.5.12
	Installer version: v1.5.12
	Operating system: #1 SMP PREEMPT_DYNAMIC Wed, 22 May 2024 13:47:12 +0000 6.6.31-2-lts
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Base theme: adapt to system
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on

RECOMMENDATIONS:
	none

Additional information

The issue illustrated:
screenshot_1716661874

However, when switching to Tab Indentation - the “gap” disappears (entire indentation is now a single tab character)
screenshot_1716661911

But oh, it gets weirder.

When 4 spaces indent is used, if there’s no text on the like (so, like after a line break when Smart Lists is turned off) - the cursor is actually correctly positioned at 4 spaces from the line start. But the moment any text is entered - the “gap” comes back.
screenshot_1716662040

When indent of 2 is used - the behaviour is 100% as expected, with no issues
screenshot_1716662094

And the cherry on this cake is - when the ident of 8 is used:
screenshot_1716662142
The result is IDENTICAL to setting indentation size to 4! (below for comparison)
screenshot_1716661874

What is even weirder is that when indentation set to 8 - attempting to enter 8 whitespaces manually results in the “gap” appearing by itself after 4 spaces are entered, and the remaining 4 spaces ended up across from it, resulting in indent of 12.
screenshot_1716662948