Bug when using | within a table

Steps to reproduce

Copy this table with code snippets in the second column

Operator Symbol Effect
And a&b a
Or `a b`

Expected result

The third row should have as its second column the code snippet a|b. It should ignore the | because it’s a code snippet.

Actual result

The table interprets that a|b are two different columns.


Obsidian version: v1.2.8
Installer version: v1.0.0
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:54 PDT 2022; root:xnu-8792.41.9~2/RELEASE_X86_64 22.1.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


If the codebase is OS and in Github I can try to make the fix through a PR

There’s an existing bug report.

(Obsidian’s not open source, tho the community plugins are.)

|And|`a&b`|On if both are on|
|Or|a\|b|On if one is on|
|Xor|`a^b`|On if only one is on|
|Not|`^a`|Inverts bits|
|And not/bitclear|`a&^b`|AND on the NOT of b|
|Shift left|`a<<n`||
|Shift right|`a>>n`||

I found a workaround by using |. This makes the pipe render where it should, but this doesn’t work within two backticks as code snippets - then it renders both the \ and |, when the \ should be hidden.