[Bug] Weird behaviors when making callouts (and potentially when just formatting text)

Steps to reproduce

  1. Open up Obsidian and a file.

  2. Make sure the option “Auto pair brackets” is on.
    (If you have Admonition plugin installed, let it auto-complete the syntax will also always triggers this bug no matter the status of this option.)

  3. On an empty line, input exactly these:
    > [!note

  4. Touch the end of the line so your cursor is now behind the auto-completed bracket.
    Manually typing the ] to replace the auto-completed one will not trigger the bug.

  5. Hit enter (multiple times) and see the bug go wild.

Expected result

Everything worked as it should be (blockquote syntax, new lines, cursor position, etc.)

Actual result

…Weird stuff happens.

Environment

  • Operating system: Android 11 (OneUI 3.1), on Samsung Galaxy S21 Ultra
  • Version: Obsidian Mobile Insider v1.2.0 (Build 50)
  • Debug info: Not accessible cuz mobile.

Additional information

This bug happens on both Live Preview and Source Mode.
It also ramdonly triggers when just normally formatting text, but not so often.
I tried to connect my phone to my computer to see the error log, but nothing comes out on the console.
I will try to attach a screen recording vid below.

Screen_Recording_20220410-184151_Obsidian InsiderTest.zip (3.2 MB)

Can’t seem to upload .mp4 files directly… So here’s the zipped file.