[Bug] UNDO not recovering from a delete and File recovery not finding recently worked on note

Steps to reproduce

work on a single long note for several hours. Added lots of text, mostly code blocks. Added comments in the code blocks.

highlight a code block I want to use elsewhere.
command c to copy, move the other app command v to paste
back to obsidian and inadvertantly hit the delete key. Highlighted code block was deleted, Tried to undo and nothing was recovered. Went to file recovery plugin and looked at the snapshots but the only things in there are all in a single folder and did not include the note I had been working on.

Expected result

Either the undo should have undone and recovered my delete of the block or I should have found the note in a snapshot and been able to recover it that way.

Actual result

Undo did not work and there were No snapshots of the note in question exist


  • Operating system: Mac OS X Catalina 10.15.7
  • Obsidian version: 0.12.12

Additional information

1 Like

I can’t reproduce “Delete a selection cannot be undone”

In you file recovery, search for the note name you were working on?

Yes, I scrolled past all the file names and none of the most recent ones were in the list. I had created, edited and moved to a new folder LOTS of separate notes over the past week and none showed up in the snapshot list of files. Just on the 21st I created 19 new notes and not one was in the snapshot. That is part of why I was confuesed. The error was mine, I hit delete when I shouldn’t have but I was not prepared for the failure of finding at least one older rev of the items in question in the list.

I’m fully prepared for it to be me, but I can’t see how and in any case I want to know what I did wrong (other than hit delete) so I can use the recover in future if I need it.

You need to search not just scroll the list.

The only thing I can tell you is that if you have moved a file, a new entry is created after you edit the file in the new location.

I have tried but I can’t reproduce what you are describing. If you a list of reproduceable steps that result in snapshot not being created let me know.

Sorry, got derailed, I can reproduce the issue but I need to document the exact steps for you.