[Bug] Search (and find and replace) does not work in the current file in edit mode

Platform

[ ] iOS
[x] Android

Obsidian Mobile version: v0.0.17
Mi A2 Lite (Android 9)

Search (and find and replace) does not work in the current file in edit mode. The search bar does not appear. In view mode, search in the current file works.

4 Likes
  • Search and replace
  • Search in current file

Is not working for me in Android. Obsidian version 1.0.3

1 Like

Ditto. Search box nor keyboard does not come up at all. Makes it hard when trying to find something in my longer notes.

Mobile version 1.0.3, both Android and iOS. iPhone 6S, iOS 13.5.1, and Samsung Galaxy S7, Android 8.0.

Thank you for all the work on this very helpful piece of software, and for making the mobile version available.

1 Like

for android search is possible in current file through command palette selecting search current file option .this is working in preview mode.

2 Likes

Ah, yes, thank you for the reminder. It does work in preview mode on both iOS and Android for me also, just not in edit mode.

Problem is, I usually need to find something to edit or otherwise work with it. If I find my search term in preview mode, then switch to edit mode, it is no longer visible, as toggling between the two changes my place in the document.

Normally, I rarely use preview mode.

I am also having this issue on iOS and iPad OS. Search within current file simply does nothing.

1 Like

Here too. on iPad OS, search within file does nothing.

Still having this issue, and it’s becoming a huge problem for me – almost a deal-breaker. The only way I’m currently able to get around it is to open the file in an external editor (Ulysses), but this is a massive kludge.

1 Like

agreed … I’m wondering if some mobile CSS hack can help with this; as it seems like maybe the UI is just not showing up in a visible/usable place … unfortunately, haven’t found any information on this forum on how to target / hack the mobile styles easily.

Neither “Find” nor “Replace” work in v1.0.4 on iOS. When I invoke these commands, nothing happens.

See screencast video at https://i.imgur.com/iteoDMt.gif

Steps to reproduce

  1. Open a note.
  2. Try to invoke “find” or “replace” either vía the command pallet or the ellipsis menu.
  3. Nothing happens.

Expected result

I expect there find/replace dialog to appear.

Actual result

Nothing happens.

Environment

  • Operating system: iOS 15.0
  • Obsidian version: 1.0.4

More proof that Black Holes do exist. Your post has just disappeared beyond the Event Horizon

Same here with iOS/iPadOS Vers. 15.0 and Obsidian Mobile App Vers. 1.0.4.
Neither Find nor Replace shows any responds in Edit mode when the function is called from the file’s hamburger menu.

Very unfortunate :slightly_frowning_face:.

I’m having the same issue with the latest android app. I won’t add the technical details, as it is clear this is a widespread bug, but would appreciate a fix

iOS 15.0.1, Obsidian 1.0.4

Same++

In a note, edit mode (iPhone): Pull down for command palette > type in “sea” then press “Search current file” and the command palette just drops away and you are back in the note. Same for “Search & replace in current file”. Tried using the default theme and it’s the same, so not theme related.

In preview mode, Search current file and Search all files works as expected.

EDIT: I noticed the other day there was a pinned “mobile issues” post that listed search/find/replace as not working in edit mode. I can’t find it now in Safari(mac or iPhone) or the DiscourseHub app. Maybe someone can actually get the pinned “known issues” to stay at the top of the mobile section, then there won’t be so many posts about issues being worked on. :slight_smile: