Bug: Obsidian window totally freezes on my iPad and on iPhone keeps on reloading

Please add [Bug] or [Feature] to your post title, then delete this line.


[x ] iOS

Obsidian Mobile version: v0.0.xx


Since this morning, when I was working, my Obsidian window totally froze (when a pdf file was loading). Since then, I have been unable to access Obsidian and working with it on my iPad

  • I closed Obsidian and relaunched, no change
  • I closed the iPad, relaunched, no change
  • I deleted Obsidian app, reloaded from the App Store, accessed my vault from local, when no community plug in allowed, it worked; then I synced again, when no plug in allowed, it worked; when I allowed for community plugin, it froze again (with mention index refresh).
  • I tried to deselect all plug ins from my Mac, and re synced the iPad, was again blocked.
  • Same problem with my IPhone, the app keeps on reloading…

It seems to be coming from a plug-in (up-dated this morning), but I have no hint on which one as I have 82 plug in installed, and 21 were updated this morning.

I am trying to rework with an other vault.
Any other hint on how to proceed would be welcome.
Thanks a lot

Do any of the plugins seem like they might use the index? For example, I had a problem where Obsidian often restarted when I created a new file, and the culprit turned out to be Waypoint (which lists folder contents in certain files).

If that doesn’t help, the Divide And Conquer plugin can help you find which plugin is the problem (given the nature of the problem it’ll probably still be a tedious task, but less bad).

I had to disable several plugins myself. OmniSearch (indexes whole vault) was one culprit, but even Dataview, Annotator, Strange New Worlds were wont to cause problems.
One has to figure these things out for oneself as they go along.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.