[Bug] Link to Obsidian note not working on iOS, works fine on Mac


[x] iOS
[ ] Android

Obsidian Mobile version: v0.0.xx

v1.3.0 (63)
API v0.15.6

I have put links to Obsidian notes in my Things To Do with the Copy Obsidian URL function. Link works fine on Mac. On my iPhone the same link opens the currently opened note, but not the note specified in the link. Behavior seems the same linking from other apps to Obsidian on Mobile.

I have a Shortcuts shortcut that uses an Obsidian URL and it works correctly for me on iOS 15.6.1 (same Obsidian versions as you). Have you tried it with Obsidian in Restricted Mode?

Thanks for your replay. I tried Restricted Mode, that wasn’t it, but while doing that I stumbled across the cause of the problem. It is not Obsidian. My Obsidian URL was in the Notes field of my Things task, which I guess is a text field or something, or at any rate there was a line break after “obsidian://open?vault” and it recognised it as such and so it did as requested, which is open the vault. :wink: The same URL in a checklist field in Things works find. So no bug on the Obsidian. But thanks for taking the time.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.