[Bug] iPad freezing and crashing. Unusable

Platform

[X ] iOS
[ ] Android

Obsidian Mobile version: v1.0.4


New Obsidian user. It’s working great on my Mac. Vault stored in iCloud. iPad app has been unusable to me. It freezes after about 30 seconds of use (time is very consistent) then crashes another 30s to a minute later.

I have tried deactivating the few 3rd party plugins I use (which are the fairly common ones…Kanban, Advanced Tables etc)

Same behavior if I leave open the vault on my Mac or not.

Anyone else experiencing this? Anything I can do to try to troubleshoot and fix?

Is this on first launch, or have you used it successfully in the past?

iCloud Drive-stored files are hard to wrangle, so when the app first launched on the iPad, Obsidian forces iCloud to download all of the files in your vault because it needs every one available in order to operate. This causes some freezing and odd behavior on first launch.

If you give it a while (and “a while” could be five minutes), it is able to download all of the iCloud Drive files, and then it works as expected.

Thanks for the quick response.

This has been on first and all subsequent launches. I noticed on the first launch it had a message about building indexes which seemed to complete fine. Based on what I see in Files, it looks like all the files have downloaded.

I supposed I could trying moving the vault to another cloud service but really like to keep my stuff in iCloud.

If you have the chance, try opening it and leaving it running without using it for a few minutes. See if that helps.

I use a vault with a few thousand files totalling >3gb with iCloud Drive.

I had tried that a few times before (I thought). Letting it sit for 10 minutes now seems to have cleared up the issue. I’ll keep an eye on it and report in if it recurs.

Thank you for the help.

1 Like