[Bug] iOS: CJK IME unable to work continuously when there are long text in the note

I tried Sougo, with the latest mobile app on testflight(1.2.2 56) and I still have this issue.

Using Sougo, at some time, I though that I have gotten rid of this issue, but few second later, the issue shown up again.

1 Like

I spent a few hours trying to get this fixed but unfortunately I was unable to find out exactly why the editor/IME was misbehaving.

I have filed a follow-up with the upstream editor library.

Please follow the discussions here: iOS IME loses focus if longer then editable block · Issue #797 · codemirror/codemirror.next · GitHub

2 Likes

OK. I will see what I can do. :+1:

2 Likes

A reply coming from the member of the codemirror team is attached:

Notice that dev team has marked this issue closed, could you please check it?

2 Likes

Codemirror claim to have fixed this. This is breaking my obsidian usage. Hopefully merge it asap? Registered just to post this. This is not only a mobile issue, also affecting mac usage.

1 Like

I don’t think this was included in that build.

1 Like

I have updated to the latest version on iPadPro but the Chinese editing support is as bad as few months ago. Please fix this bug, it’s the biggest issue for Chinese users.

Unfinished Pinyin are turned into English letters when typing Chinese characters, and the Chinese character selecting box would flash to the top left corner.

The issue happens when Chinese character selecting box hits the right edge of the page, or simply when there are too many characters in one file.

1 Like

I also have the same problem on my ios, it has not be solved now.

1 Like

You are right…
:frowning:

And thanks for the replies above…

1 Like

Agreed with users and commenters above. This has to be fixed ASAP because the app is not useable for Chinese users with this bug. It’s been multiple months and it’s been happening for way too long. Is it an upstream bug, how / who / where do we go to get this fixed?

I tried to follow the closed codemirror thread but don’t understand as I’m not really a developer. Can a new issue be posted or reported to / followed up with Apple if it’s an issue with Apple? I’m not quite sure I understand what an upstream error is. Could there be a way to change the software to work around the bug? Why does this happen in obsidian but not other apps?

In any case, please fix this bug, it’s making the app unuseable.

I think the author of the codemirror had fixed this bug. And according the the discussion in the discord, about a month ago, this upstream bug was going to be fixed in the next major release of the obsidian mobile, which is, now we know, not 1.3.2.

I know it is difficult for us, but, anyway, let’s be patient.