[Bug] iOS app extremely laggy / freezes

I’ve seen this behaviour across apps in iPadOS 15 with the smart keyboard, FWIW.

Exactly! Especially with latest Beta (5?), the problem is with iPad Air. App is un-usable. Similar issues with other apps are no longer detected in those apps. I have been continually reporting issue with Apple Feedback app. Any selection of external keyboard (Logitech OR Apple Magic) Space Bar or direction/arrow keys causes the app to act erratically or freeze. Shut down and reopen is required to use app again.

Ryan - it makes sense :wink: when more than one user makes very similar observations with essentially/potentially somewhat different circumstances and the same result. The Common Denominators seem to be the Obsidian mobile app in iPadOS15(Beta) ONLY with an external keyboard.

@amrnt @ryanjamurphy It could be the Accessiblity “full keyboard access” setting.

See my post here. When I have full keyboard access turned on, I get nothing but problems in Obsidian. With it off, everything is just fine.

This setting explains why it has everything to do with the hardware keyboard :slight_smile:

1 Like

Interesting theory, but I’ve had system-wide issues with an external keyboard on iPadOS 15 without that accessibility setting enabled.

Chiming in - I tried 1.0.3 and 1.0.4 beta on my iPhoneXS 512GB, iOS 14.7.1 with a vault of around ~1700 files (all .md and .png). I had the freezing too, it was so bad I had to force quit the app – total lockup and unresponsive UI.

Not sure what process was happening in the background (some kind of index being built etc) but eventually it seemed to settle down. It was really frustrating at first. I submitted some feedback through TestFlight but not sure what else I can do to help debug this. Is there a logfile somewhere?

When you had problems, was it after a lot of changes had taken place in your vault? Or was it a first launch of that vault?

And what sync service was this with?

@ryanjamurphy this was after an initial seeding of the vault (to iCloud). So yes there was activity going on at first. I made a full copy of my “real” vault just to play around with the mobile app.

Yeah, initial launch always seems to have issues. Same if you come back to the vault after a lot of changes have taken place. iCloud is simply stubborn about how files are handled, and Obsidian needs to see every file in the vault. That initial downloading and indexing activity is what causes the lag, but once it’s done, it tends to perform perfectly.

The only solution I can imagine is deliberately locking down the app while this loading activity takes place, giving the use only a progress bar, loading screen, or similar.

Got it. Yes it seems to be working pretty smoothly now after a few false starts and quite a bit of waiting. A locked screen with a progress bar would definitely be a big UX improvement.

Is this experience the same when using the paid Obsidian Sync service instead of iCloud? If Sync works better that would be another big incentive to switch to it.

IIRC the Sync experience is a little better on first launch, as the files are synced from within Obsidian. Sync has also generally been celebrated for being faster/more reliable, plus the other benefits it has over iCloud.

Naturally there are tradeoffs. (E.g., I use iCloud because Sync has a max vault size.)

1 Like

I suspect it’s because the files inside the iCloud/Obsidian/{vault} haven’t completely downloaded from iCloud (it’s a new iPad) so I killed the Obsidian app and opened Files, and navigated to my vault and left it open until the cloud download icon disappeared from each file. Scrolling through the list will do that, or you can tap-hold on the file and pick Download from the context menu.

After I made sure there aren’t any pending downloads, I then opened Obsidian. Of course it was laggy but not as much as before. Maybe that’ll help?

1 Like

I have been having this same sort of issue using iCloud to sync across mobile and desktop. The iOS app would often hang or crash on initial launch, and then “catch-up” and work fine one or two launches later. I recently switched to syncing with git following these instructions:

This seems to have solved the issue and the first launch experience is very snappy now. So, for me at least, this was probably an issue to do with scanning and indexing the iCloud files on launch. Hopefully the added overhead of pulling and pushing using Working Copy isn’t too tiresome, we’ll see.

1 Like

I have the same issues using icloud on iphone . It crashes on the launch quite frequently. Some time it works but in general, it’s the point of being unusable. :frowning:
I tried uninstalling, reinstalling. etc w/o much help.

What iPhone are you using? If you check Files, are many of the files in your vault not downloaded?

I have iphone Xs Max with 15.01 version running. I don’t see files not downloaded if I see from the files app in the vault directory.

Interesting. My bet is that it’s not downloading some hidden files in your vault that are required for Obsidian to work. There’s a fix coming in 1.0.5 for that.

1 Like

I am having the exact same issue on my iPad Pro 11”. Obsidian is unusable for long periods of time, though it works without issue on iPhone and Mac.

1 Like