[Bug] iOS app extremely laggy / freezes

Platform

[X] iOS
[ ] Android

Obsidian Mobile version: v1.0.3


Just diving into Obsidian for the first time. Works fine on my Desktop with iCould folder of ~4k .md files. But the iOS app is laggy and freezes often to the point of being unusable. I realize this is pretty vague but it’s so widespread that I’m at a bit of a loss to know how to report it as a bug. The problem must be unique to me or no one would be using this app.

What steps should I take to troubleshoot, or what info can I supply that would be helpful?

Thanks

2 Likes

I could record a video of me using it if that would help.

I have the same problem, especially when using an external keyboard. The app stops responding to most and sometimes all input, including text input.

Sometimes i am able to push a button, such as switching between edit and render mode, the button will change but nothing will happen.

This happens regardless of the number of files in the vault.

Do you have some html/xml files in your vault erroneously with a .md extension?

1 Like

I can’t speak for OP but i have not and i can recreate this problem with any vault and any number of files.

What device, and what iOS version?

iPad Pro, iPad OS 15.0.
Keyboard is Logitech Folio Touch

Curious. I don’t get this behaviour at all on an 11" iPad Pro running iPadOS 15 beta 3.

It doesn’t make sense that it could have anything to do with the hardware keyboard.

Are there any large text files in your vault?

I have a 2019 iPhone Pro Max and a 2020 12.9 iPad Pro. Obsidian is quite snappy on both and I have a decent sized vault and I do use a bluetooth keyboard on the iPad. And by most accounts, the mobile app is quite responsive for most people unless you have lots of html files with mistaken .md extensions. It’s difficult to know what might be the issue in these specific cases with so few details.

Does the performance issue only show up when using an external keyboard? Is your device low on storage? How old is the device? Have you tried with a fresh vault? Different device? Fresh install? Etc…

1 Like

Well, as i said before, i can recreate the problem with any vault and any number of files. The iPad is the 2020 model (the one before M1). About 70GB free storage.

The issue for me only seems to arise when using an external keyboard and mouse, which i do 99% of the time.

sure. That was for @jackbrannen too as he was asking for assistance and didn’t know what else to provide. I’ve had some issues with iPad accessories and weird lagginess that wasn’t related to obsidian. Switching accessories fixed things :man_shrugging:. Might be something to try if you only ever see it with your keyboard attached. FWIW, I use an external keyboard and mouse and do not see the same. What I’m suggesting is your experience might not be an obsidian issue.
Also FWIW I’m not an obsidian dev, just relaying some of the common issues I’ve seen in the discord channel.

2 Likes

I have this problem on a 2018 11" iPad Pro using iCloud syncing. Sometimes the app will work fine, other times it’ll finish loading the workspace (which itself is lengthy) be responsive for 20-30 seconds and the stop accepting any user input. This happens regardless of keyboard being used.

The slow workspace loading is also a problem on my iPhone 12 Pro. The iCloud folder has fully synced but it still takes a while to load the workspace and will occasionally freeze or crash.

My vault is around 2GB and contains a lot of non-md files as I’m trying to use Obsidian as my general reference system

Edit:
iPhone is using iOS 14.7.1
iPad is using iPadOS 15 public beta

1 Like

Is it a beta problem, or can you reproduce it on iPad OS 14.7?

Don’t get me wrong, it is always good to find bugs during beta (and solve them during beta). But you are running a beta OS. There is so much work going on on the kernel and the OS itself, thus you got to expect problems.

I had both problems on iOS 14.7 and have it in the latest iOS 15 beta.

a) freeze on launch – which I can mitigate by using “Files” app and forcing iCloud sync before launching Obsidian, this feels related to vault search indexing

b) freeze in use – which I can mitigate by detaching the Apple brand external keyboard

c) problem not mentioned above: some keystrokes will not go from external keyboard to Obsidian regardless whether it’s being responsive, until I detach keyboard, force quit Obsidian, attach keyboard, and relaunch Obsidian

Combination of Obsidian, vault in iCloud, and Apple’s external trackpad keyboard for 2020 iPad Pro. I have to detach the keyboard to get Obsidian to interact with me again, or wait seconds to minutes.

I have a decade of markdown notes in subfolder hierarchy.

vault1: 3606 items, 370MB

vault2: 3810 items, 2GB

I carved vault2 out as it had PDF and image attachments

Per a question higher up in the thread, some of the .md files have incidental inline HTML, but are not .html files called .md.

I’ve seen this behaviour across apps in iPadOS 15 with the smart keyboard, FWIW.

Exactly! Especially with latest Beta (5?), the problem is with iPad Air. App is un-usable. Similar issues with other apps are no longer detected in those apps. I have been continually reporting issue with Apple Feedback app. Any selection of external keyboard (Logitech OR Apple Magic) Space Bar or direction/arrow keys causes the app to act erratically or freeze. Shut down and reopen is required to use app again.

Ryan - it makes sense :wink: when more than one user makes very similar observations with essentially/potentially somewhat different circumstances and the same result. The Common Denominators seem to be the Obsidian mobile app in iPadOS15(Beta) ONLY with an external keyboard.

@amrnt @ryanjamurphy It could be the Accessiblity “full keyboard access” setting.

See my post here. When I have full keyboard access turned on, I get nothing but problems in Obsidian. With it off, everything is just fine.

This setting explains why it has everything to do with the hardware keyboard :slight_smile:

1 Like

Interesting theory, but I’ve had system-wide issues with an external keyboard on iPadOS 15 without that accessibility setting enabled.

Chiming in - I tried 1.0.3 and 1.0.4 beta on my iPhoneXS 512GB, iOS 14.7.1 with a vault of around ~1700 files (all .md and .png). I had the freezing too, it was so bad I had to force quit the app – total lockup and unresponsive UI.

Not sure what process was happening in the background (some kind of index being built etc) but eventually it seemed to settle down. It was really frustrating at first. I submitted some feedback through TestFlight but not sure what else I can do to help debug this. Is there a logfile somewhere?