[bug] can't create vault in android app

Platform: Android

Android version: Android 11

Phone: Asus Zenfone 6

Phone version: 18.0610.2106.156

Obsidian Mobile version: v1.0.4


Hi there,

I got some trouble in creating new vault in my phone.

Even I choose “Open folder as fault”, It’s still not working.

Just like the screenshot below.

I have given all permission to the app, but it shows the error message again and again.

Can somebody help me to fix this problem?

Thanks a lot!

Second that. I do get the same error on my OnePlus 6T

I’m using Asus phones too and I have no problem.

I googled around and found this. Someone there mentioned that this could be caused by “frozen android stock file manager”. That could be the problem I think?

That link is about a syncthing fork by our beloved obsidian dev.
Nothing about obsidian’s problem of opening no folders

Because I believe the problem here is the Android system, not Obsidian.

When clicked on these buttons, Obsidian tries to open the system’s “Allow Write Permission” in the stock Files app to let you choose a folder to set as the vault. The problem then is that somehow the system doesn’t allow Obsidian to use the Files app; then error occured.

For me, even I don’t have the same problem, by disabling the stock Files app through adb I was able to repro this.

Again, I’m not sure what’s the exact case on your side, but if the case is just the Files app got disabled, then do these:

  1. Enable "USB Debugging on your phone. (How?)
  2. Connect your phone to a computer
  3. Install ADB tools if you don’t have one.
    (What is ADB?)
  4. Do adb shell pm enable com.google.android.documentsui in the adb window.

And everything should be working again.

Edit: I missed one important step up there…

1 Like

Ha. You are totally right, i forgot about debloating that package … .because i do use the oneplus stock thing. … you were 100% right
reinstalled it. (in case anybody did the same thing)

adb shell 
cmd package install-existing  com.google.android.documentsui