[BUG] App crashes

[X] Android 10

Obsidian Mobile version: v1.0.2 (from Google play store)

When I try to open my vault the app keeps immediately crashing, It is impossible to open the app.

I created a new vault without my folder with all my attachments (size 220mb) and it seems to work, but as of now it is impossible for me to load my complete vault without the app immediately crashing.

The app will crash no matter what path my vault is in.


Same problem.

I have an “Obsidian” folder in my Google Drive, synced to my desktop. I can open that with Obsidian desktop.

But when I use FolderSync for Android and sync that same folder to my phone, I can’t even open the folder as my vault with Obsidian mobile - it immediately crashes, and from that point on I can’t open Obsidian any more.

What’s strange is: I tried going into Android file manager and move all files in the synced folder to another folder, and then I could open it!

I also tried creating a new vault with Obsidian mobile, then syncing that folder to my Drive folder. I had Obsidian open during the sync and could see the folders and files being populated in real time - but when it reached roughly 80 or so folders, it suddenly crashed and then I could not open it any more.

And when I move the files out, then back into the vault, it also works again.

I have no idea why selecting everything in the vault folder (from my Android file manager), moving them all out to another folder, then moving them back into the vault folder again, would fix the problem. But it does.

Howevery, obviously this is not a viable solution to my problem since I can’t move the files in and out every time I want to use Obsidian after a sync is completed.

I have now tried another sync app, DriveSync, and same problem: As soon as I try to open the vault with Obsidian, Obsidian crashes.

Tried one more thing:

In Android file manager, I have created a folder called “Obsidian sync folder”.

When I have this as my vault, and DriveSync had synced, as explained above Obsidian crashed.

Then I created a new folder called “Test Parent”, and moved “Obsidian sync folder” into parent. Now I can open it in Obsidian!

Then I moved it back out of parent (exactly how it was originally). And Obsidian can still open it!

Then I started the sync process again. And after a while, in the middle of the sync, and when it had not even synced any files yet (because there’s nothing to sync basically, I have just moved the folder to another location and then moved it back again in my Android file manager), Obsidian suddenly crashed and now I can’t open it again!

So obviously syncing does something that crashes Obsidian, in 2 different sync apps now. And even after stopping the sync, I cannot open it with Obsidian. And even more, even after uninstalling both Obsidian and the DriveSync, and reinstalling Obsidian again, trying to open the vault with Obsidian crashes it!

Renaming the folder doesn’t help either.

But, again, moving it to another location, then moving it back again, then opening with Obsidian works!

How large is your complete vault?

Sounds like the app might have run out of memory, unfortunately. Can you share your phone’s specs?

I found the issue that was making my vault crash, I thought it was memory related but I loaded my attachments one by one until the app crashed, turns out I had a single file with “:” in its file name, I changed it and the seems to run smoothly.

Maybe your issue has to do with memory but I’d check your file names to make sure you aren’t using any illegal characters, hope that helps :smiley:

On Android, the character : is illegal. In theory, you couldn’t have a file with that character in filename. How did you endup with that file on android?

Honestly, I have no idea.

My desktop vault is on Mac where colons can’t be used in filenames.

My vault worked on Mac - with the file containing :
I uploaded my vault to Dropbox - no issue.
I copied my vault to my Android device.

I don’t understand how that file ended up with : but I am the only person who uses my vault so I must have named that file with a : at some point, but I don’t even know how?

Cant think of anything else, sorry I can’t be any more help.

Hey all, running Android 11 and also experiencing app crashes on initial loading of a directory as a vault. The last output I see is a toast that says:

Obsidian is indexing your vault…
This should only happen once.
Some functionality may not be available until this is complete. (0/95)

Then the app crashes. I’ve tried:

  • rebooting the app
  • restarting my phone
  • reinstalling the app
  • clearing the app cache

I’ve verified my directory, and its sub directories’, contents do not contain a file name with any characters that are a-z, 0-9, dot, dash, or underscore by running:

$ find . -type f | grep -i '[^a-z0-9\.\/_\-]'

at its root.

I’ve also verified that if i open a small sub directory of the root, the app loads as expected.

Any advice on how to get more info on the crash? I’d love to read and provide any logs…

Hi Silver, was the question for me?

I doubt it can be a memory issue, since the problem disappears when I simply move the folder somewhere else, then move it back again. Or could it?

I have a Google Pixel 5.

The folder I’m syncing and trying to open with Obsidian is 1.1GB.

Did you try simply moving the directory to somewhere, and then opening it?

If that works, it’s the same as me. See [BUG] App crashes - #4 by yusufhgmail.

However, anytime I start syncing that folder again, Obsidian crashes.

Interesting @yusufhgmail, I’m glad you mentioned that, as that worked for me!

I moved my directory up one level:

$ mv new-notes ..

And I was able to open new-notes as a vault. The original directory this was under was simpley titled Git.

I’d obviously prefer to be able to control my directory structure but this is a fix for now.

I’m still happy to explore why it’s crashing by reading and providing logs, I’ll just need to be told where they are.

Edit: I must have misunderstood what you wrote until now, as my Obsidian app also crashes on reopening… Hahaha so close to having it work! Gah this is frustrating ha

@yusufhgmail probably unrelated but what path do you have the directory you use as your vault stored at?

I’m having the same problem. I created a folder on my phone and synced using DriveSync and Google Drive. I installed and tested the Obsidian app, creating a new vault on my phone and it worked fine. But as soon as I “opened folder as vault” using my synced folder, the app crashed.

Even worse, the first few times I tried, I had to uninstall the app as it wouldn’t launch without crashing. After reinstalling, I could keep it working as long as it used my “dummy” local vault, but as soon as I pointed it back at the synced folder, it crashed again.

Now, I can’t even get the app to launch after a fresh install.

I assume that there must be a corrupt file somewhere that causes the Obsidian mobile app to crash.

Very annoying, but I guess the app is very new and this is part of the teething process.
I’d be interested to hear if you fix your issue.

Edit: After deleting all the folders that I’d used as vaults off my phone, the app is once again able to launch.

Edit: The official help available from within the mobile app (“How to set up mobile sync”) specifically mentions “Third party sync” options and links to Dropsync and Folder Sync". So surely it must work for most people?

Yeah this sounds exactly like our issue we’re having to. Just a tip, if you want to launch Obsidian without crashing and without uninstalling, you can move your underlying directory opened as a vault. That will work until the next time you open the app.

I’m still waiting to hear back how to debug this, as it’s incredibly frustrating haha

Let me know if you learn anything and I’ll do the same

Do you have weird character in the filenames? How big is your vault? The app may also crash because it can’t fit your phone RAM.

I created my filenames using Obsidian, I don’t think there are any disallowed filenames. The vault is less than 10Mb.

I don’t think it is a RAM issue.

you may have created your filenames in Obsidian, but there are different characters allowed in different OSes (users wanted direct control).
So if you are not using Obsidian Sync, it is on you to make sure that your sync solution doesn’t create funky files. Do you have files that contain #:% or other weird character?
Why don’t you try to move one directory at time from the vault that doesn’t work to the one that works to see if you can narrow down the issue?

Reading various forums, it seems that quite a few people use google drive to sync obsidian. I haven’t seen many people with my problem.
I’m going to assume from that that the most likely problem is files with weird characters in my Vault. All my files work with the desktop app, so there must be a difference between mobile and desktop that causes mobile app crash.
My next step from here will be to search for and try to eliminate files with “weird characters”, but I can only guess what that means.
It’s a pity that the app can’t parse this out rather than crashing.
Thanks for the tips though.

Hey @WhiteNoise,

For context from the rest of the thread, I searched throw my notes programmatically to try to find any files with weird characters and could not find any.

I’ve verified my directory, and its sub directories’, contents do not contain a file name with any characters that are a-z, 0-9, dot, dash, or underscore by running:

$ find . -type f | grep -i '[^a-z0-9\.\/_\-]'

Is there any way we can procure some log or crash report to understand why our app is crashing rather than guessing?

I’m also not convinced this is a ram issue, as I can restart my phone and only open this app and have it crash. Additionally my directory / vault only contains raw mark down as a flat directory. IE no images etc.