[Bug] Android Gboard "Double-space period" broken


[ ] iOS
[x] Android

Obsidian Mobile version: v1.1.0

(I originally posted this yesterday, but deleted it as it was formatted poorly.)

The recent v1.1.0 release on Android broke a standard feature implemented in Android’s GBoard keyboard. This is a regression from the previous v1.0.5 version.

Steps to reproduce

  • Confirm GBoard’s “Text Correction → Double-space period” is enabled in it’s settings.
  • Type a word and tap space twice.

Expected result

  • The first space tap should add a space after the word
    • Foo | (pipe is cursor location)
  • The second space tap should insert a period (.) after the word, followed by a space
    • Foo. | (pipe is cursor location)

Actual result

  • :green_circle: The first space tap should add a space after the word
    • Foo | (pipe is cursor location)
  • :red_circle: The second space tap removes the space, leaving the cursor at the end of the word
    • Foo| (pipe is cursor location)


Operating system: Android 12, Pixel 3
Debug info:
	Operating system: android 12 (Google Pixel 3)
	Login status: not logged in
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Blue Topaz
	Snippets enabled: 0
	Safe mode: off
	Plugins installed: 3
	Plugins enabled: 2
		1: Calendar
		2: Auto Link Title

	Update installer: installer version too low, please download from https://obsidian.md/download and reinstall.
	Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

I tested this with my standard vault and a newly created vault. In the new vault, I tried the following to see if it had any affect (none did):

  • Turn off all plugins
  • Turn off all editing options
  • Tried Live editing and Source editing
  • Removed all hotkey bindings

Might also be related to the GitHub issue in [Bug] 'long press back button to delete whole words' option in Microsoft Swiftkey keyboard does not work inside obsidian v1.1 - #2 by koala

1 Like

Might be related to this issue.

Do you know how to turn this Microsoft feature off? Or do we have to wait for someone fixing the bug?


Following the discussions on GitHub, it seems to be an upstream issue with the code editor package that’s being used. The Obsidian devs (I believe based on GH contributions) are discussing with those devs on the issue with GBoard & SwiftKey.

1 Like

Writing here to confirm this problem. Gboard works fine with any other app.

1 Like

+1 with this. Thanks for posting. I came here to do this.
This makes it very difficult to type.


This is probably fixed in 1.3.0, finally. I can’t test it, because I lost my Android phone, but autocorrect is fixed, so I assume this is fixed as well.

Unfortunately not fixed. New user here, just installed 1.4.0, came here via Google to report this observation.

1 Like

Not fixed for me either (neither on Samsung tablet not phone)

1 Like

Yeah I was just able to test it, not fixed :(. Very annoying. The behaviour has changed though. Instead of the second tap removing the space, it now just does 2 spaces, as if the double space setting was turned off. So slightly less annoying, but still annoying.

1 Like

I’m going to add my tuppence worth here too as I’m struggling to use Obsidian due to a similar bug (probably the same one).

I can’t do a period (.) using SwiftKey on a Note 9 anymore - it just does a space instead. That’s a new one since this big overhaul.

I also still can’t type in Thai using SwiftKey on Obsidian without getting those red dot characters, which is one of the linked bugs someone posted above. That’s sadly been the case for a long long time now.

These keyboard issues seem to be quite widespread though, because I had a scroll through the Obsidian reviews on the Google Play Store and there are many people reporting these issues - either not able to do punctuation or getting the red dot characters everywhere.

It’s not a bug with any one particular keyboard… I see reports of people struggling with Samsung Keyboard, Gboard, SwiftKey, etc. It just seems to have different funky behaviour between each.

1 Like

I’m experiencing this as well (Obsidian 1.4.1 on Android, with Gboard), along with some weird behavior related to autocorrect and predictive text, which I’m going to write a separate bug report about when I have the time.

1 Like

Also experiencing this on Android on version 1.4.1. Is there any hope of progress?

As a higher-level point, text editing on Android just feels notably “janky”. I am regularly pulled out of the flow of entering my thoughts by nonstandard keyboard/text behavior.

A comment earlier in this thread says “I can’t confirm because I lost my Android phone”, which concerns me that there’s no one involved with the product who actually uses it on Android; I suspect if there were, these editing problems would take precedence over other feature work. I was happy to pay for Obsidian Sync to support development, but if Android is only a kind-of supported platform, I’ll probably look for another solution. What is the situation?


I am also encountering this issue on Obsidian 1.4.1.

will be fixed 1.4.2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.