Broken Image and pdf display on Obsidian

Description of the problem

The Images and PDFs in my vault are not displayed when I try to embed them in notes. Images and PDFs are not visible even when I open them in a separate tab/window within Obsidian
The images in my notes that were visible until very recently are no longer displayed. Furthermore, new images that I add to my vault are not displayed as well. However, thankfully, the images have not been corrupted and are properly displayed when I use an external application to view them.

The problem persists even in other vaults that I have created. This led me to think that this is some problem that relates the the app’s config files. However, images are properly rendered in new vaults that I created after the problem began

What the Problem looks like

This is what happens when I embed a note in a note.

Console Output

This is the output when I try to embed an image

This is the output when I try to open a pdf

Things I have tried without success

I have tried uninstalling Obsidian, deleting the config files at /.config/obsidian, and reinstalling the app.

Have you tried to activate save mode, basically, to deactivate all community plugins?

Maybe you’ve some old plugins conflicting with Obsidian

I have tried to see if the problem persists in “restricted mode” and it does.

Or try this, from Obsidian open new vault, remove this vault, then open system file manager, rename the vault folder, add it as a new vault.
This way Obsidian should refresh any cache or index of vault files.

@nahi Hi, thank you for the reply. I have tried what you suggested but it didn’t resolve the problem


This is the output in the “Elements” section. Not sure if this will be of help but I am posting this for reference.

Edit 1: The problem with PDFs not loading has somehow been resolved on its own by the looks of it. I am able to manually resolve the problem with images simply by renaming them. However, I would appreciate a better solution since I have over a thousand images in my vault and it would be quite cumbersome to rename all the images.

Yeah, looking at your last screenshot we can see how you use some illegal characters, Slash /
Computer keyboards allow us to type anything, but file / folder paths don’t allow any characters.
I mean, obviously you can but this will trigger errors

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.