Bookmarks not showing

Steps to reproduce

Bookmark a page
Cannot see any anything in the bookmarks panel. No existing bookmarks, no bookmark groups, no newly saved bookmarks.

Expected result

To see bookmarks and bookmark groups I have made earlier and to see new bookmarks.

Actual result

Nothin in the bookmark panel - no groups, no bookmarks.


Obsidian version: v1.2.8
Installer version: v1.2.7
Operating system: Windows 10 Pro 10.0.22621
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: off
Legacy editor: off
Base theme: light
Community theme: Minimal v6.3.2
Snippets enabled: 1
Restricted mode: on

I have updated all plugins and themes.
I have tried a variety of themes under both light and dark, including minimal and default.
I have disabled all community plugins and restarted Obsidian
I have disabled and enabled the bookmark built in plugin and restarted Obsidian.
I have tried reproducing the issue in Sandbox Vault - but it works fine there.


can you attach here a copy of your .obsidian/starred.json and .obsidian/bookmarks.json? You can also DM me those files.

It sounds like the view encountered an error when trying to render your bookmark list. Could you share a screenshot of the developer console so that I can debug what might have gone wrong? The bookmarks.json file might be enough too, as WhiteNoise suggested.

To check for errors, first open the developer tools by pressing Ctrl-Shift-I on Windows/Linux or Cmd-Opt-I on macOS, and then go to the “Console” tab. If you want to save the error to a log file, you can right click on the error and choose “Save as…”.

Hi WhiteNoise Thank you for picking this up and asking for the json files. That lead me to look at them (in VS Studio) and realise that I had probably corrupted the bookmarks.json trying to manually add a canvas ! So as my intention today is to start afresh with bookmarks (after watching a Nicole Van Der Hoevan video) I have removed those two json files from my vault and can now make and see bookmarks. All fixed now. Thanks.

1 Like

Sorry Liam… I have fixed it now by removing the bookmarks.json and letting obsidian create it new. Thanks for your help.

No problem at all, glad it’s fixed!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.