Bold text not working in reading view


the Problem i am currently facing is that Text ist not made bold in reading view, but it is in editing view.

reading view:

editing view:

As you can see, bold and italics combined is working as well as italics on their own.

I am on Version 1.3.7.
I did some research and all i could find is that it would be some sort of Font Issue. I tried changing fonts, restarting all of that but had not luck.

I hope someone knows how to fix this, thank you for your time in advance

Did you try the troubleshooting steps? How does it look in the Sandbox vault, etc.?

Also, what OS are you seeing this on?

I am on Windows, i did follow the troubleshooting steps.

In the Sandbox Vault it looks fine.

I am not using any community plugins.
I tried disabling every core plugin and restarting obsidian after each one i disabled.
I also tried re-installing. Same issue.

So, if it looks fine in the Sandbox, it’s something specific about your vault (probably not your OS or fonts).

Did you just set it up or have you been using it for a while?

I just set it up yesterday. I though a restart might help, so i waited until today to see if it was fixed after a reboot.

This is up to you, but with Obsidian closed I’d move the .obsidian (settings folder) out of your vault and restart. This won’t touch your notes, but will set all settings to default and remove any themes or plugins you may have installed. As you just set it up yesterday, this seems the easiest.

Then you can set things up fresh or replace some of the original .obsidian items to see if the problem comes back or not (I wouldn’t bother though).

Oh, i found the Issue.

I tried copying just the bold text to a new vault and it worked, after i copied the whole page i had the same issue again.

The issue is cause by having the bold text right under a HTML h1 tag.


If i move it down a line it’s correct again.

But thanks a lot for your help :slight_smile:

Ha! yeah, mixing HTML in your notes does work, but it can break the Markdown formatting if you aren’t careful.

Also, instead of using HTML for this, I’d consider writing it as:

# Important

and using a community theme’s settings (usually in the Style Settings plugin) or a CSS snippet to color h1s red.

If i Ise the “# Important” would there also be a way to only color this Heading red instead of all H1s?

Got it.

Yeah, setting red would be for all h1s. You could get more specific with the CSS, “only h1s in this particular note are red”, “only the first h1 in notes are red”, etc., but if it’s random with no pattern… I guess HTML is the way to go. :+1:t4:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.