Blurry window and text

Here’s another.

Is this only Obsidian that is looking blurry for you? Or any other apps?

Did you just recently upgrade to MacOS 11.2.3? (That was released early in March. I wonder if this coincides with your issue.)

Only obsidian is looking blurry. No other app, including electron based.

I did upgrade to 11.2.3 recently. I’m not sure if that may have caused the issue as I hadn’t opened obsidian for a few weeks.

It may be the Translucent window setting in Appearance. If it’s on, turn it off and see if problem goes away.

The Translucent window setting was already turned off.

Also, updating to 0.11.9 doesn’t help with the issue.

close obsidian
delete this folder </Users/yourusername/Library/Application Support/obsidian>
open obsidian

Tried this too. Still window and text are blurry.

have you tried uninstalling and reinstalling obsidian?

Does the help vault looks blurry too?

By this, I think you mean moving app to trash and downloading another from website. Tried that too.

I am not a mac expert. I am not sure if there are DPI scaling settings per app on mac. You can look into that.

@WhiteNoise Will you please ping the developers so that they can help me out.

@yasar84782 I tell you with maximum respect and I don’t want this to sound offputting. This is community-based support. Unless you are paying a commercial license or support the development with Catalyst, you are not really “owed” any support.

What’s your installer version? Not obsidian version, installer version?

1 Like

Whitenoise is right. The developers cannot be pinged for every single individual problem people have. There are over 11700 users on this forum.

What kind of Mac are you on? What kind of monitor/screen are you using? What resolution are you using? Are you using the “Default for display” setting, or did you set your screen resolution to a custom setting?

In Big Sur, the “font smoothing” options are gone. You used to be able to change it in the preferences. There are a couple of threads where people have tried to fix it. If you are comfortable with technical fixes and the Terminal, you could try this:

(But font smoothing may or may not be the problem. I’m on Big Sur too, and I don’t have the blurry text problem you do.)

Both, the installer and obsidian version is 0.11.9.

I have 13’ MBP, default display, default resolution, “Default for display” settings

Running the command defaults -currentHost read -g AppleFontSmoothing in terminal gives me The domain/default pair of (kCFPreferencesAnyApplication, AppleFontSmoothing) does not exist, which I think means that font smoothing is disabled by default.

The thing that I’m not able to understand is that why only obsidian, and no other app, has this issue.

Obsidian developer console gives me following screen details.

  1. availHeight: 800
  2. availLeft: 0
  3. availTop: 0
  4. availWidth: 1280
  5. colorDepth: 24
  6. height: 800
  7. orientation: ScreenOrientation {angle: 0, type: “landscape-primary”, onchange: null}
  8. pixelDepth: 24
  9. width: 1280

Note that the app uses/detects 1280x800 as screen resolution instead of native resolution. This is clearly an issue/bug with the app.

We have a sizable number of mac users and you are the only one tht has ever reported this problem. I am inclined to believe that this is your computer problem and you should find if/where macos determines the scaling of individual apps.
I am pretty convinced that MacOS has the ability to run individual apps at custom resolutions. See

Perhaps something as simple as this might help:

I’ll keep the bug report open to see if we gather more data points.

1 Like

Or font smoothing might be on by default, and adding the entry would disable it. It really depends what the default is. Those two linked threads imply that font smoothing is the new default. (I have no idea though.)

(I don’t necessarily endorse changing those preferences unless you’re comfortable with the Terminal. The bug might be coming from somewhere else, and this might have unintended consequences.)

@WhiteNoise @rigmarole Thank you for your help. I found the root cause.

Using a Retina display - Apple Support helped. As it turns out, “Open in Low Resolution” was selected in Get Info panel.

This is the solution from the support page:

  1. Quit the app.
  2. Open the Applications folder.
  3. Click the app once to select it, then choose Get Info from the File menu.
  4. From the Get Info window that opens, select the checkbox labeled ”Open in Low Resolution.”
  5. Close the Get Info window and open the app again.
1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.