Bluetooth Keyboard No Longer Works with Android v1.5.8

Steps to reproduce

Connect a Bluetooth keyboard to the Android phone (Samsung S23, One UI v6.0, Android 14) and attempt to type. The first character appears, but then the cursor disappears. You have to touch the screen to get the cursor to appear again, but after another character is typed, the issue repeats. Basically you have to touch the screen where you are typing after each character or just hitting shift.

Did you follow the troubleshooting guide? [Y/N]


Expected result

The characters appear on the screen in the note.

Actual result

After each key is pressed on the BT keyboard, I have to touch the screen before entering another keystroke.


Additional information

I have tried two different BT keyboards and the results are the same. I have restarted the phone. Other apps on the phone work OK with both the BT keyboards I have.

1 Like

does it happen in a new vault?

Yes, I tried a new vault.

Just tried to uninstall & reinstall; same symptoms.

Also, when in an existing note that is more than a page view long, the space bar pages down after the cursor loses focus in the note. This may be the default behavior that I may not have noticed previously because the cursor would always be active/in focus.

Can you post a screen recording of this happening in a new vault? (2.0 MB)

See the attached zip that contains the screen recording.

which virtual keyboard are you using? Samsung Keyboard? GBoard?

1 Like

Samsung. In the settings, it is the only option. The virtual keyboard is working fine. The issue is with an external Bluetooth keyboard. That was working up until the latest version was installed at some point yesterday.

Is there a way to obtain the v1.5.7 release until this is addressed?

I am experiencing the same issue with a Pixel phone and the Swiftkey virtual keyboard. I watched the screen recording and it is exactly what I experience as well.

Something that looks different from my normal experience with Obsidian is the dark green cursor with the teardrop shape underneath, which looks like a selection prompt on Android. If I type on the virtual keyboard, the teardrop disappears and the cursor goes back to its more usual muted color, allowing me to type normally. But if I instead type on the BT keyboard, the cursor and teardrop disappear completely until I physically touch the screen again.

This is only happening in the Obsidian app. I was able to type my note up in Keep with the BT keyboard and then cut and paste it into Obsidian by hand.

Does it happen if you use Gboard?

We tried with two different phones within the team and we can’t reproduce.

I am not sure the shape of a cursor is a factor.

Which Bluetooth keyboards are you using?

Ah, the issue does not occur for me when using Gboard. It is only when using Swiftkey. Not sure if this has any bearing, but within Swiftkey I use the Dvorak layout while Gboard is set to standard QWERTY.

My BT keyboard is a Samsers foldable, something I picked up off of Amazon but not a brand I know much about.

I tried microsoft swiftkey on my pixel 6a and it works for me

I am on a 4XL with Android 13

You can change Gboard to Dvorak layout

If you don’t see Gboard icon: go to system settings/keyboard.

Thank you, @AdrianoCzelentano, I am aware of what Gboard can do and how to swtich. I was sharing layout information in case it had any bearing on troubleshooting the issue. I will use Gboard as a workaround whenever I am typing in Obsidian for now, but I use Swiftkey for its multilanguage support (I regularly switch between four languages and it keeps up pretty well with autosuggestions and autocorrections).

I will be getting a new phone in the next couple of weeks. If the issue is not fixed by then I will update this thread on what happens with the new phone.

I installed Gboard and made it the default and now the Bluetooth keyboard works. Switching back to the Samsung keyboard, the problem returns.

The BT keyboards I am using are an older Microsoft Sculpt and a newer generic folding one off of Amazon (

@JimBezdan that generic keyboard, the Samsers, is the same brand as the one I am having difficulty with, only the model is different.

will be fixed 1.5.9


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.