Blue Topaz font

Things I have tried

Test 1

I have tried using snippets without theme. It worked using

/* Change font in editor */
.markdown-source-view {
    font-family: "Virgil 3 YOFF", monospace;

/* Change font in preview */
.markdown-preview-view {
    font-family: "Virgil 3 YOFF", monospace;

It works in reading mode but does not affect preview nor line preview mode. It seems overwritten.

Test 2

I am using the “Blue Topaz” theme, i tried using snippets with the same code as earlier, it now seems overwritten in both reading and preview mode.

Test 3

I tried modifying the “Blue Topaz.css” in multiple way without success.

  • Added "font-family: “‘Virgil 3 YOFF’ , monospace” to the body but did not work
  • Replaced every 'var (–default-font) with ‘Virgil 3 YOFF’ but did not work
  • Tried to add ‘Virgil 3 YOFF’ at the beginning of font list for it to be default, did not work either.

What I’m trying to do

My ultimate goal is to make the system font apply on every mode in the “Blue Topaz” theme.

I quickly looked looked through the options for this theme using the Style Settings plugin and was able to change the font on the editor for all modes on Detail Settings > Typography > Font Family > Main Font

1 Like

Perfect solution, work after a quick restart

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.