Block Reference Behavior with standard markdown links

To reproduce the issue:

  • disable wikilinks
  • ensure a block exists with a reference tied to it in some file
  • in another file:
  • type ![[, the dropdown list then pops up
  • arrow to the file, then press ^ - the link completely autofills with no option to choose a reference in the file. This may or may not be expected, depending on what the devs intended when wikilinks is disabled/off. Using my test file as an example:
    • when you press ‘^’, autofill generates this: ![test1](test1.md)
  • however, you can first press # and then press ^ which then works as expected
  • now you get the drop down that lists the sections of the file you can reference. choose one
  • in my test case, here is an example of the result: ![](test1.md#%5Eblock1)
  • switch to preview mode and notice this works as expected, then switch back to edit mode
  • notice the %5E that automagically gets inserted. I think that is the ^ symbol
  • replace %5E with the ^ symbol, then switch to preview mode. This works in preview mode: ![](test1.md#^block1) (notice that both the # and ^ are present here)

Expected result

I understand that wikilinks and block references are Obsidian features. I really like the block references. The initial behavior of ignoring the pressing of ‘^’ and just fully autocompleting the link might be expected in this case, as I turned off wikilinks (at least that is what I think the devs intended), although this could be a bug and should be allowing you to choose the block reference here. I do like the fact that even though I turned wikilinks off, I have extra block reference text in my markdown file that I can use outside of Obsidian to refer to a specific section of another file, and that this shows correctly within Obsidian.

I am hoping that even with wikilinks turned off, you can still choose a block reference normally, because in preview mode this still works.

I would also expect that instead of %5E, a ^ symbol would be generated, since this works in preview mode.

Actual result

You cannot initially choose a block reference when wikilinks is turned off.

Environment

  • Operating system: Windows 10
  • Obsidian version: 9.15 and 9.17

Thanks for taking a look at this.

Edit: remove erroneous information

I can’t reproduce your problem for headers
the autocompletition for [[note# works fine for me.

The autocompletition for blocks doesn’t work.

Some features are very ackward or impossible with standard markdown links.
We’ll think about this.

I failed to add a few headers in my target file while I was testing. You are correct and it works fine. I will edit my post so I do not confuse anyone who reads this in the future.