Blank Graph screen

Hi All,

Firstly, please excuse any misuse of terminology during this request for help, apologies in advance.

I have been using Obsidian for a research project for over a year. In an attempt to maximise the efficiency of referencing, I recently connected my vault to Zotero through the “Citations” and “Zotero Integration” plugins by Jon Gauthier and mgmeyers respectively. This requires me to Export “Mdnotes” files from Zotero to Obsidian.

Unfortunately, since I have implemented these changes I have no longer been able to view the Graph. When i select the graph icon on the left-hand side of the screen or via the “more options” route the page becomes a blank off white colour (my Obsidian vault is set to light mode)! I then have to close down Obsidian and restart.

I have tried re-downloading Obsidian and starting again but no joy! Unfortunately, that is as far as my expertise goes!

I would be so so so grateful if anyone could help in anyway!

Many thanks in advance!

P.S. Sorry I nearly forgot I use a Mac, macOS Ventura 13.0.1

Does the entire app go blank, or just the graph pane?

Have you tried updating all your community plugins? Themes also need to be updated.

And if you could, post your “Show debug info”, for more clues.

Thank you for your swift reply!

In answer to your question, yes, the entire app goes blank!

I have just updated all plugins and rebooted Obsidian, but unfortunately, this has not remedied the fault!

Sorry, I will have to look into “show debug info”, as I have not seen this before!

Again, thank you for your speedy response!

Ctrl-P to open the command palette in Obsidian. Then type “Show debug info”.

Obsidian version: v1.1.9
Installer version: v0.14.2
Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:30 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T8103 22.1.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 3
1: Icons v0.3.0
2: Zotero Integration v2.3.2
3: Citations v0.4.5

Update installer: installer version too low, please download from Download - Obsidian and reinstall.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Downloading and reinstalling doesn’t (1) update the installer, and (2) resolve the issue with the graph? The installer is almost certainly a core issue here …

Thank you for your words of wisdom, they are greatly appreciated!

Sorry to be naive, but where can I locate an updated version of the installer? The link provided only directs me to the latest “Obsidian version v1.1.9” download.


The installer is updated when doing a full installation of Obsidian, but not when Obsidian does an ‘incremental’ update initiated through: Settings > About. Incremental updates update Obsidian itself but not the architecture it is built on, and the installer is that architecture that we’re targeting here.

So long as the vault is stored in its own folder and not in the sandbox …

  1. Quit Obsidian.
  2. Go to the Applications folder on your Mac and select Obsidian.
  3. Click on the File menu when you’re in the Applications folder and you’ll see an option that says ‘Move to Trash’. Either click on that to move Obsidian to the trash can or press the OPT key and ‘Move to Trash’ will change to ’Delete Immediately’. That second option will remove Obsidian from your Mac completely (but not your vault, so long as your vault isn’t part of the sandbox).
  4. Download a new copy of Obsidian and install that.
  5. Reopen the vault.
  6. The installer should update
  7. And hopefully the graph will work

I have tried opening both 'Research" folders, but still, the fault persists.

Even though I am using the latest version of Obsidian v1.1.9 I am still seeing an installer update notification in the top right-hand corner of the screen?

Did you actually follow @eightning’s instruction to download the v1.1.9 Installer and run it?
Or is your Installer version still v0.14.2, like your Debug Info shows?

Yes, I did, and yes the installer version is still v0.14.2

Screenshot 2023-02-02 at 14.45.08

I don’t get it. If you download the Installer from the link that @eightning provided and run it, the Installer should definetly be updated. This is weird.

Is it because I am opening an existing file (“Research”)?

Should I try renaming the Mac file (“Research”) and searching for it during initiation?

I regularly use the Installer whenever a new version is out (I don’t use the In-App Auto Update function) and I don’t have to do anything but run it.

As you can see, I tried renaming the file, but it is still requesting that I need to update the Installer!

You are referring to renaming something. That shouldn’t matter at all.

The issue is with your app installation. There must still be an old version on your system.

If you go to this path, you’ll find your app settings: ~/Library/Application Support/obsidian

Before following any advice here, I suggest to BACK UP your vault and this settings folder. Make a copy somewhere safe. I’m not a dev. This isn’t an official answer:

  • Close Obsidian first.
  • Copy the settings folder, then delete the original.
    • Or just rename it ~/Library/Application Support/obsidianBACKUP
  • Reopen Obsidian. You’ll have to browse for your vault again, because the list of open vaults will be forgotten.
  • The settings folder will be regenerated automatically with fresh settings.
  • Your vault settings, hotkeys, and plugins, etc. are stored in your vault, and should be remembered and safe.

This might fix the glitch with your installer.

I must apologise, but I am not sure how I navigate to the app settings folder. Where do I enter:

Sorry again for my naivety! I am so grateful for your help!

Is it this file that needs to be removed from the Mac HD?