Black Screen on Apple Devices Related to iCloud Sync

I attempted to use the Obsidian app on my Apple devices but ended up permanently deleting my account and manually deleting the iCloud data. After reconsidering, I reinstalled the app and created a new account. However, I am encountering a persistent issue where the app displays a black screen on both my iPad and iPhone, only functioning properly when I disable Obsidian in iCloud syncing. But then I am unable to enable iCloud syncing within the app.

Any suggestions on how to resolve this issue and get the app functioning again?

Is this solved?

Thank you. I fixed the black screen problem as you said: In the settings, I went to the list of apps that use iCloud, disabled the switch next to Obsidian and then re-enabled it.

I’m uploading the black screen and solution video here in case anyone else has this problem.

But the sync thing seemed too complicated and it doesn’t work as smoothly as Logseq. Folders hang separately on their own. It doesn’t look organized like a single database. Maybe I can try to use it again later.

1 Like

Hi mfdoom, thank you.
Your post was One of the first ones I have found on the forum.
I tried it immediately.
Indeed, when I turned off Obsidian sync to iCloud, the app could launch again.
However, when I turned the sink on again, the app turned black screen…
Or when I tried it again : turn off sync, launch application, I see it works (but not being able to put an iCloud folder), closing the app, turning the sync to iCloud on again, launching the app, and then… Again, the Obsidian icon and then black screen.
Is there any step I have missed? Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

continue here: