Big note file loading error

I have a plain txt note file, full size is 517 MB (542,342,193 byte). The software interface gets stuck when you open it. When it’s not open, it’s simply stored in the notes directory, and some of the functions can be quite unusual.

Actual result

Environment

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: Windows 10 Pro 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Blue Topaz v2023112601
Snippets enabled: 0
Restricted mode: off
Plugins installed: 17
Plugins enabled: 13
1: Custom Attachment Location v0.0.9
2: Latex Suite v1.9.0
3: Custom Note Width v1.0.2
4: Epub Importer v0.2.9
5: Importer v1.5.6
6: Full Calendar v0.10.7
7: Latex OCR v0.6.5
8: LaTeX-like Theorem & Equation Referencer v2.2.0
9: MathLinks v0.5.3
10: Completr v3.2.0
11: Local Images Plus v0.15.9
12: Style Settings v1.0.7
13: Style Text v0.1.0

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

file name unchange:

full softwere get blank

Can you try copying the note into the Sandbox vault, or a fresh test vault? Or at least test with default theme and no community plugins.

Try to isolate whether it is the note, or something in your vault, like a plugin.

That is a pretty huge note though. Maybe it is just struggling to load it. It might depend on your computer’s memory too. And you might ultimately have to consider splitting this note into multiple separate chunks. (I’m not speaking for the devs. Maybe there is a bug or a solution here.)

we are not going to support file of that size and perhaps we should block you from opening in them.