Backticks not autoclosing on mac and us-international keyboard

Hi, I just switched from windows to mac and cannot get the backticks to autoclose on my us-international layout.

It happens for both the inline comments and the block comments. Neither of them gets autoclosed.

Steps to reproduce

  • Select us-international keyboard layout on your mac.
  • Open a new document
  • Type a backtick and then the space bar

Expected result

I expect an inline code block. that is, two backticks and the cursor in the middle

Actual result

A single backtick and the cursor after it


  • Mac OS Ventura 13.0.1
  • US-International keyboard layout
  • Debug info:
    Obsidian version: v1.1.8
    Installer version: v1.0.3
    Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:15:09 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T6000 22.1.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 9
    Plugins enabled: 1
    1: Ozan’s Image in Editor Plugin v2.1.6

That’s normal, US international uses ` to create accented letters.
Depending on how the os manages this, it may be impossible for autocomplete to work.

Hi @WhiteNoise , thanks for your answer.
That’s weird because it worked with the same keyboard layout in windows.