Backlinks not working in the same folder?

Going through and trying to organise notes that were, until today, just a disparate gaggle of documents. Backlinks, aliases, sensible titles, the whole thing.

However, “unlinked mentions” doesn’t seem to work within the same subfolder.

I have a book, which is a collection of essays. Each essay has its own note, the book gets a folder, inside a “Books” folder. Books->[Title of Book]->[Title of Essay].md

Separately, I have a “Writers” folder, then letter folders, then a note for each writer.

In two separate essay notes, I’ve cited other essays from the same book , in the form “[author], [Title of essay]”. The author shows up as an unlinked mention, the essay itself does not. The only thing I can think of is that it’s due to them being in the same folder but I don’t see why that should prevent an unlinked mention from being detected.

Okay, so it’s not the same-subfolder thing, as I now have it happening across folders as well.

Both problem folders have folder notes. Is there an incompatibility somewhere?

Has Unlinked Mentions finished searching? Are the phrases definitely the same as the note name, and not linked? Do the names have anything in common?

“Finished searching”?

It’s not related to folder notes either, it’s happening in folders without them. I even tried mentioning a note that isn’t in a subfolder at all, no dice. I have no idea what causes some of them to randomly pop up, but it working seems to be the exception rather than the rule.

Ah, I think I’ve got it. “Unlinked incoming” works, “unlinked outgoing” doesn’t.

So…is there a reason outgoing links wouldn’t be working?

Unlinked Mentions runs a search on the vault to find the mentions. The search isn’t necessarily instant, especially in a vault of thousands of notes, so you may see a progress indicator (a colored line moving from left to right) until it has finished searching the vault. Until the line has stopped moving, the list of unlinked mentions may not be complete.

The unlinked mentions in the Outgoing Links tab are words in the current note that match the names of other existing notes. Does that describe the results you see, or are some missing?

I don’t see a line, and it’s been several days at this point, so there’s no way it’s still searching. I see absolutely nothing under unlinked outgoing mentions for any of my notes. Incoming unlinked works fine, and linked works fine in both directions, but outgoing unlinked is just completely empty.

Does your note contain any words or phrases that are also the names of notes in your vault but aren’t links? If not, then outgoing unlinked mentions will be empty.

1 Like

Yes, it does. I’ve literally sat there just typing out the names of all my other notes, nothing happens.

Strange. It seems to be working for me. All I can think to recommend is to run thru the troubleshooting steps if you haven’t yet.

Tried the sandbox, but neither outgoing nor incoming unlinked mentions work there. Disabled all my community plugins and rebooted, and now neither outgoing nor incoming unlinked mentions work in my main vault either.

There hasn’t been an Obsidian update since I first installed the software, so that’s all fine.

Maybe a few screenshots and the text as it’s typed in your note could help here? The bare minimum example in the Sandbox will do if you don’t want to show your main vault.

In my 2023-12-05 note, I have:

# main-embed

- longform 
1. 🩴👘👠🧤⛑️

And in the Outgoing Unlinked mentions tab:

I tried moving 2023-12-05 as well as the other notes in and out of different folders and the Unlinked mentions list remained the same.

Hmm. It seems to suddenly be working now, and remains so with community plugins re-enabled. Weird.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.