Background startup - No Splash screen [Feature Request]

Use case or problem

Hide or remove the Obsidian start splash screen [Loading Workspaces… etc] that starts Maximized (at least on Windows) no matter how you set up the app to start minimized or even using a 3rd party app like nircmd to try to force the minimization. If your setup is out of the box the splash screen is quick, but the more add-ons you add the longer it gets. My vault takes 3-4 seconds to open, which is fine if it was happening in the background, but having the splash screen pop up and having to click to minimize it every time I start the app is annoying. I also have 3000+ notes and that seems to add lag time as well. As the app allows more functionality, I can’t imagine the splash screen is going to load faster. Why is it there at all? Remove it please.

Proposed solution

Create an option to start the app without the splash screen. Would be nice if it was the default as there is no reason currently for the Obsidian splash screen… it doesn’t even says Obsidian.

Current workaround (optional)

There is no work around (at least on Windows).

As a workaround, you can always use the Obsidian Tray plugin, which you can set to launch Obsidian in the background and auto-minimize to the taskbar instead of the tray area, this way Obsidian launches and you can click on the taskbar icon to open it after you estimate it must have loaded its plugins.

Hi @woofy31 , I tested the plugin called TRAY, but it still shows the splash screen. Though I did think it hid the splash screen slightly earlier when I enabled the hide feature. Not really what I wanted, but nice feature for someone who wants Obsidian to be running in background all the time. It would eliminate all the splash screens during the day, just not the first one of the day. Pretty good work-around. Thank you.

1 Like