Autopair highlight not working properly ==

Steps to reproduce

  1. Enable autopair bracket editor feature
  2. Type 2 equal signs

Expected result

  1. There should be 4 equal signs when you type 2
  2. The cursor should be in the middle (in b/w 2nd and 3rd equal signs)

Actual result

  1. When you type 1 equal sign, a second one appears
  2. The cursor is in b/w the 2 equal signs

The current implementation does nothing useful: it is not intuitive (does not follow the pattern of other autocomplete b/c highlight takes 2, not 1, equal sign, so it should only trigger with 2 equal signs), it misplaces the cursor, and it does not create enough equal signs.


  • Operating system: osx
  • Obsidian version:0.7.6

Additional information

1 Like

I was going to write the same thing. Also not working on windows 0.7.6 (no CCS).

I work fine for me when typing one “=”, but does not work when i type “==”

1 Like

Workaround for now: use the custom hotkey or select the text first and type = twice.

1 Like

Thank you for this. It’s not that urgent; it’s more of an annoyance b/c I often type = (a single equal sign) when writing notes so it’s just a hassle to delete the extra equal sign.

Understood! Just want to make sure you guys are aware of the workaround (you probably do already :slight_smile:) while being annoyed by this bug.

Also if you don’t care too much about pairing * and _, you can disable “Auto pair Markdown syntax” in Settings - Editor.

1 Like

I just noticed this bug as well. I was typing stuff like x = 7, y = 5, and it gives me two equal signs every time i even type it… quite annoying and makes it unusable really.

I think its kind of urgent because it makes the editor look like some bug-ridden mess… usually these types of bugs are caught by automated testing. Im assuming there isnt one for Obsidian.

1 Like

We have removed autopair for = in 0.7.7.
It’ll be added back when it works properly.

I noticed that this exactly problem is also happening with the “*”