Automatically get closed after open

It has been working for several months. But today It suddenly get closed. After I reopen, it get closed soon (in 3 seconds). I reinstalled it, tried both 1.1.19 and 1.1.18 but both not work. I remove the files in the folder \AppData, but it still not work.

My system is Windows 10.

I use obsidian everyday (I really can’t live without it).

(Please use the template when creating a new bug report.)

Hard to say what the issue is without more info. Does the app itself crash, or just the vault?

The vault in question probably has some corruption in its config files.

  1. Quit Obsidian.
  2. Go to the vault’s folder, reveal hidden files, then copy the .obsidian folder elsewhere to back it up.
  3. Delete the .obsidian folder from your vault folder.
  4. Relaunch Obsidian, and use the “Open folder as vault” feature to open the vault folder again.

Obsidian will launch as a blank slate vault, but your notes and other files will all be there. You’ll need to reconfigure your settings/plugins from there.

I just move my own vault folder elsewhere, so obsidian can not find it when it start. So it is not affected by my vault folder.

And it still crashes? Even with no open vault?

Silly question, but have you tried rebooting?

1 Like

Thanks. It works after rebooted. I was just preparing usb stick to reinstall the system. You answer saves me a lot of time. Thank you very much.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.