Automatic creation of named "icon" files

First, search the help docs and this forum. Maybe your question has been answered! The debugging steps can help, too. Still stuck? Delete this line and proceed.

What I’m trying to do

Every time I create a folder in the sidebar and insert a new note in it, a blank file named “icon” is automatically created in the folder.
When I click on this file, it opens in my computer’s default text editor.
When I read the information on this file (equivalent to looking at the properties on a PC), I just see that its full name is "icon?
What do these “icon” files correspond to?
How can I stop it creating them automatically?
Thank you in advance for your answers.

Things I have tried

Have you tried these steps? This seems like it could be a plugin issue.

1 Like

Thanks for your repy.
I have just have tried it. Hasn’t solved.

Please open the command palette, run “Show debug info”, and paste the output here.

Opening the command pallet is Cmd+P ?
If yes, when I open it (I’m on a french version), I don’t see any command looking like showing debug info .
What do I have to do to have acces to this debug info ?

The translation file says it’s “Afficher les informations de débogages”.

Got it. Here below.

Obsidian version: v1.4.13
Installer version: v1.4.13
Operating system: Darwin Kernel Version 22.3.0: Mon Jan 30 20:42:11 PST 2023; root:xnu-8792.81.3~2/RELEASE_X86_64 22.3.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 1
Restricted mode: off
Plugins installed: 8
Plugins enabled: 4
1: Editing Toolbar v2.3.1
2: Advanced Tables v0.19.1
3: Highlightr v1.2.2
4: Table of Contents v0.2.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Do you perhaps have an app or setting enabled on your computer that customizes the folder icons in Finder?

Not as far as I know. Unless have I never try to customize displays (like icons or else) on this mac, either through dedicated app or imbedded settings.

Have an idea on how I could check it further ?

The debugging steps should have ruled out Obsidian-based causes. Do you use any other apps to access files in your vault folder?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.