Autocorrect text entry broken in Obsidian on Android

Steps to reproduce

  1. Enter text in any note on the latest version of Obsidian for Android.
  2. Make any typo and have your soft keyboard attempt to fix it.

Expected result

Autocorrect should work the same as in any other app: replacing mistyped words with correct ones, adding automatic punctuation, etc.

Actual result

Only the final character of the corrected word is deleted. Or, if the word is the first in a line, it is replaced but the carat jumps back to the front. Behaviour of both my soft keyboards (Gboard, Fleksy) is wildly different within Obsidian compared to any other Android app that deals with text (such as Chrome where I’m typing this right now).

Environment

  • Operating system:
    Android 7.0
  • Debug info:
    SYSTEM INFO:
    Operating system: android 7.0 (samsung SM-N920I)
    Login status: not logged in
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Safe mode: on

RECOMMENDATIONS:
Update installer: installer version too low, please download from Download - Obsidian and reinstall.


Additional information

I tried this with Live Preview both off and on. Behaviour seems the same either way.

2 Likes

Same thing. Autofix does not work + can’t delete entire words using keyboard: https://play.google.com/store/apps/details?id=com.syntellia.fleksy.keyboard. Tried with both modes as in description.

1 Like

I’m having this issue using Gboard but only with text next to check boxes.

When using Obsidian on Android with Gboard without a checkbox, autocorrect works fine. As soon as I click into a checkbox to edit it’s text, or I create a new checkbox. Autocorrect stops working.

1 Like

Back again—I’m noticing that this issue hasn’t been added to the known issues list. Not to sound demanding (sorry if I do) but Obsidian on Android has been practically unusable for me ever since the update that added live preview. It’s a huge shame because I was overjoyed to discover this app and immediately made it my primary editor on mobile and PC, and then just a few weeks later an update came along and broke it. :frowning:

Would any devs be able to please let me know if this is likely to be fixed? I know Obsidian is free, but I would very happily pay for the Android app if it worked again, that’s how good it is.

1 Like