Attempting to Delete Freezes Obsidian

Steps to reproduce

When I try to delete a file, my Obsidian freezes.
I am getting this issue through two ways:

  1. Right clicking on a file in the explorer panel on the left side and clicking delete
  2. Opening up the Command Palette and selecting Delete current file

Freezes both ways. Since this started happening I have had to go to Finder to delete a file instead of being able to do it from the Obsidian interface. One note about the freezing. When it freezes, it doesn’t fully freeze. Meaning I can still scroll up and down on a note with my mouse scrollwheel. I just can’t click in to anything or edit.

Did you follow the troubleshooting guide? [Y/N]

Yes

Expected result

I expect the file to be deleted.

Actual result

It does not delete. It just freezes.

Environment

NOTE: It says I have 19 plugins enabled but I tried turning them off (see below) and still had issues.
SYSTEM INFO:
Obsidian version: v1.5.8
Installer version: v1.4.13
Operating system: Darwin Kernel Version 23.3.0: Wed Dec 20 21:28:58 PST 2023; root:xnu-10002.81.5~7/RELEASE_X86_64 23.3.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Feather v0.0.0
Snippets enabled: 2
Restricted mode: off
Plugins installed: 36
Plugins enabled: 19
1: Advanced Tables v0.21.0
2: Spaced Repetition v1.11.1
3: Style Settings v1.0.7
4: Tag Page Preview v0.0.12
5: TagFolder v0.18.5
6: Templater v2.2.1
7: Things Link v1.1.2
8: Things Logbook v0.2.0
9: Upcoming v0.4.0
10: PDF Highlights v0.0.4
11: ProZen v0.3
12: Snippet Commands v0.0.2
13: Calendar v1.5.10
14: Dataview v0.5.64
15: Excel to Markdown Table v0.4.0
16: Heading Shifter v1.5.1
17: Hide Sidebars on Window Resize v1.1.0
18: Natural Language Dates v0.6.2
19: Divide & Conquer v1.0.0


Additional information

I turned off all plugins one by one. I tried going into safe/restricted mode also. I changed appearance to the default theme and turned off all snippets. Still freezes. I then turned off all core plugins and still freezes.

Help! Anyone have any ideas what else it could be?

How many files do you have in your vault?

Post a screen recording of this happening after you enable safe mode and restart obsidian, thanks.

About 4,200 files total. I will post a screen recording when I get a chance.

Seems to be working now. I’m not sure what changed but I’ve turned all my plugins and themes back on and files do delete now. If it happens again I’ll get a screen record back up here.