Attachment folder path not sticking, not working for paste

Steps to reproduce

installer v1.1.9 (updated to 1.2.1, problem persists)
Turned off community plugins. Default theme.

  • Selected a new “Default location for new attachments”
  • It only works sometimes. Always with drag and drop. Only sometimes with paste. When I make a brand new note, it is more likely to work.
  • When it doesn’t work, it uses the default location that I had set previously.
  • Tried multiple restarts. It was yesterday that I made the change.

Additional information

Part of the new folder path includes the character Δ. The old one included Ω. Those are the only special characters involved.

I tried using a folder with no special characters, didn’t resolve. The paste action still defaults to the old folder.

Screen grab had to be zipped to upload →
Screen Recording 2023-04-04 at 8.37.32 (499.1 KB)

Post a screen recording of this happening in the sandbox vault. The screen recording should show your settings and the whole screen.

Tested in sandbox. Works as expected.

you can try your own vault with restricted mode on and restart.

Ok. I had tried restricted mode before, but maybe not restrict and restart together.

Paste Seems to work as expected now with restricted+restart. But, it also worked sometimes yesterday with community plugins enabled. (Seemed dependent on which note I was pasting to)

Oh damn. I think I found the problem.

I do have a plugin called Paste Mode, which has its own setting for paste directory : p

Thanks for fast response, sorry for the hassle, @WhiteNoise!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.