Assigning NEW hotkeys not working

Steps to reproduce

  • Restart computer
  • delete obsidian, download latest and re-install
  • restart computer

Did you follow the troubleshooting guide? [Y/N]

Yes. Same result as video I uploaded. No new hotkeys are being assigned. Existing/already assigned are working though.

Expected result

Be able to assign any hotkey to any action

Actual result

Nothing is happening. Tried different actions, same behavior. Key presses aren’t being recorded.


Obsidian version: v1.5.8
Installer version: v1.5.8
Operating system: Darwin Kernel Version 23.3.0: Wed Dec 20 21:28:58 PST 2023; root:xnu-10002.81.5~7/RELEASE_X86_64 23.3.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Dataview v0.5.55

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

screen recording: Dropbox - File Deleted - Simplify your life

are you pressing also cmd/shift or some other modifier?
I don’t see it on the screen

yes. I found the issue. The left cmd of my external keyboard seems to be malfunctioning. I tried the actual KB of my laptop and it’s working.

This can be closed now. Thank you for taking a look.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.