AppImage on Debian 12 arm64 locks up on start

I have downloaded the latest AppImage for Linux Arm

Running on Debian 12 with all of the latest updates in VMware on a MacBook.

What I’m trying to do

Open the application and use it. However, it will open and I will have a pop-up for one of my reminders (plugin), and then the app locks up, turns into a black square and it will proceed no further.

It seems like some of the vault synced, but hasn’t progressed any further. The vault directory hasn’t changed size in a while.

Things I have tried

I wondered it if it was any of the plugins, so I moved the plugins directory out of the local copy of the vault. I restarted the app, but now, it just goes from loading the vault data to the black screen.

Attached a screenshot so you can see the application (black square) and what’s displayed on the terminal. The text from the start of the application follows:

2023-11-06 19:48:32 Loading main app package /tmp/.mount_Obsidiogdtly/resources/obsidian.asar
2023-11-06 19:48:33 Checking for update using Github
[142517:1106/] After loading Root Certs, loaded==false: NSS error code: -8018
2023-11-06 19:48:34 Success.
2023-11-06 19:48:34 Latest version is 1.4.16 (insider)
2023-11-06 19:48:34 App is up to date.
sendToFrame() failed: Error: Render frame was disposed before WebFrameMain could be accessed
Attempting to call a function in a renderer window that has been closed or released.
Function provided here: app.js:1:1274943
Remote event names: blur, focus

I am getting the same error messages when i tab out and back into obsidian on WSL Ubuntu 20.04, but my obsidian manages to start and it works perfectly fine.

Updating to Ubuntu 24.04 made the error messages disappear.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.