Annotator plugin bug with recent catalyst update, pdf flushes to left side and can't click on it

Steps to reproduce:

  • I’m not sure what the issue is but whenever I use the annotator plugin ever since I got the most recent update (v.1.5.0), the PDF keeps shrinking in size widthwise where every time I try to click on the page it shrinks to half the size, then when I click again it opens back up to full size and vis versa. As a result, I cant highlight anything to annotate it. I’ve tried uninstalling and reinstalling the plugin, using different PDFs and notes. I haven’t changed anyhthing else like themes or new plugins.

Did you follow the troubleshooting guide?


Did you really try the above steps in the sandbox vault (or a just any vault started in restricted mode, no snippets and default theme)?
Yes I did the same thing in the sandbox vault (installed the annotator plugin on there) and the same issue happened.

Expected result

What do you expect to see after carrying out the steps above?
I expected to be able to click on the PDF in annotation mode without it resizing and so that I can highlight text to annotate it.

Actual result

Instead the file keeps resizing each time I click on it making it impossible to highlight any text.


Obsidian version: v1.5.0
Installer version: v1.4.13
Operating system: Darwin Kernel Version 23.1.0: Mon Oct 9 21:28:12 PDT 2023; root:xnu-10002.41.9~6/RELEASE_ARM64_T8103 23.1.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Base theme: dark
Community theme: AnuPpuccin v1.4.4
Snippets enabled: 2
Restricted mode: off
Plugins installed: 55
Plugins enabled: 47
1: Note Refactor v1.8.2
2: Dataview v0.5.64
3: QuickAdd v1.6.0
4: Tag Wrangler v0.6.1
5: Natural Language Dates v0.6.1
6: Templater v1.18.1
7: Collapse All v2.0.0
8: Recent Files v1.3.8
9: Omnisearch v1.19.0
10: Text Extractor v0.4.8
11: Opener v2.1.2
12: v0.1.19
13: Auto Note Mover v1.2.0
14: Style Settings v1.0.7
15: Theme Picker v1.0.9
16: Footnote Shortcut v0.1.3
17: Better footnote v1.0.1
18: Webhook Plugin v0.0.6
19: Juggl v1.5.0
20: Breadcrumbs v3.6.4
21: Periodic Notes v1.0.0-beta.3
22: AidenLx’s Folder Note v0.16.5
23: AidenLx’s Folder Note - folderv component v1.0.0
24: Archiver v0.26.1
25: Folder Note Core v1.3.5
26: Hotkeys for specific files v1.4.0
27: Hotkeys for templates v1.4.3
28: Linter v1.20.1
29: Open vault in VSCode v1.2.1
30: Plugin Update Tracker v1.5.2
31: Settings Search v1.3.10
32: Advanced Tables v0.19.1
33: Paste URL into selection v1.7.0
34: Reminder v1.1.15
35: Admonition v10.1.1
36: Emoji Shortcodes v2.2.0
37: Google Calendar v1.10.14
38: Hider v1.3.1
39: MetaEdit v1.8.2
40: Buttons v0.4.19
41: Chronology v1.1.11
42: Obsidian Git v2.22.0
43: Excalidraw v2.0.4
44: Minimal Theme Settings v7.3.1
45: Tasks v5.2.0
46: Obsidian42 - BRAT v0.7.2
47: Annotator v0.2.10

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Screen Recording of issue: Zight Recording 2023-11-28 ...


we don’t take BR involving plugins. moved to help.

Sorry about that - I’m a first time forum poster. And thank you for moving it to the right spot!

i have same issue , how do you fix it ? :shushing_face:

Obsidian has been updated recently to 1.5.3.
I have the same behavior.
If I reinstall the 1.4.16 version, I have back the normal behavior.
Appreciate any help. Because I’m not planning to stay indefinitevely to the 1.4.16.

the bug has also been reported here

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.