Android App when editing soft keyboard switches on and off, characters are inserted inside wiki links and before headings

Steps to reproduce

When editing a note of mild complexity, seems to start around one screen of text which contains wikilinks and headings.

Expected result

Being able to edit the text.

Actual result

The soft keyboard gets switched on and off in a loop. When the keyboard gets hidden, the full text gets marked, and unmarked when the keyboard is shown.

Sometimes characters are indefinitely inserted inside wikilinks and in front of headings and tags. These charcters show as a red dot and a space.


  • Operating system: Android 13
  • Debug info:
    Operating system: android 13 (samsung SM-G988B)
    Obsidian version: 1.4.1 (83)
    API version: v1.0.3
    Login status: not logged in
    Live preview: off
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 34
    Plugins enabled: 32
    1: Kanban v1.5.1
    2: Templater v1.16.0
    3: Calendar v1.5.10
    4: Advanced Tables v0.18.1
    5: Dataview v0.5.47
    6: Outliner v4.2.1
    7: Mind Map v1.1.0
    8: Tasks v1.20.0
    9: Tag Wrangler v0.5.5
    10: Obsidian Charts v3.7.1
    11: Checklist v2.2.12
    12: Annotator v0.2.8
    13: Admonition v9.0.5
    14: QuickAdd v0.8.0
    15: Dynamic Table of Contents v0.0.27
    16: Footnote Shortcut v0.0.9
    17: Timelines v0.3.2
    18: Emoji Shortcodes v2.2.0
    19: DB Folder v3.1.0
    20: Supercharged Links v0.9.3
    21: Style Settings v0.4.12
    22: Recent Files v1.3.5
    23: Omnisearch v1.9.1
    24: Note Refactor v1.7.1
    25: Natural Language Dates v0.6.1
    26: Full Calendar v0.9.5
    27: Enhancing Mindmap v0.2.4
    28: Breadcrumbs v3.6.4
    29: MetaEdit v1.7.2
    30: Juggl v1.4.0
    31: Tracker v1.10.9
    32: Find orphaned files and broken links v1.8.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information

I tried disabling all community plugins, bat this didn’t change anything. I reinstalled and it still happens.

It was not from start, but started after some time.

The Samsung keyboard has problems with Obsidian (search the forum for details). Try Google’s keyboard (Gboard?) or a third-party one.

Interesting, that it did not happen right from the start.

I hope it get’s resolved some time, especially first time users getting this may just uninstall again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.