Android 13: Properties transfer to another note if pull-down is used

Steps to reproduce

  1. Setup pull down to open a note (random note might work but I’ve been using daily note)
  2. Make sure properties are “visible”
  3. Begin writing property on one note (edit note)
  4. Without clicking off of properties, pull down
  5. The current property should have have updated if it already existed on pull down note. It also looks like any missing properties from edit note are also transferred, but I’ve only seen this once

Did you follow the troubleshooting guide? [Y/N]

Since this is on mobile, I can’t do a sandbox. Pull down seems to just trigger a command palate option without exiting the current context though, so I don’t think it’s related to vault changes.

Expected result

Pull down should open the note, but shouldn’t be in properties, and definitely shouldn’t bring over any extra properties

Actual result

Pulling down has the cursor in whatever property that you were previously editing, with the value that you had set in the previous note. It also seems to bring in all the previous notes properties.


Operating system: android 13 (samsung SM-N986U)
Obsidian version: 1.4.16 (114)
API version: v1.4.16
Login status: logged in
Catalyst license: none
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Things v2.1.19
Snippets enabled: 0
Restricted mode: off
Plugins installed: 13
Plugins enabled: 12
1: Editor Syntax Highlight v0.1.3
2: Templater v2.0.0
3: Dataview v0.5.64
4: Periodic Notes v0.0.17
5: Calendar v1.5.10
6: Linter v1.22.0
7: Tasks v5.5.0
8: Smart Random Note v0.2.1
9: DB Folder v3.5.0
10: Media DB Plugin v0.6.0
11: Meta Bind Plugin v0.11.0
12: JS Engine v0.1.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

The bug is easy to reproduce but I assume since it requires editing the pull down option in mobile it hasn’t been seen often.

Will be fixed in mobile 1.5.x

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.