< and > key does not work for Hungarian keyboard layout in the new editor

To insert the < and the > character, I have to press Alt+Shift+Y or Alt+Shift+X when using the Hungarian keyboard layout.

Currently, when editing the note, this does not work. Instead, the cursor jumps to the beginning or end of the note. It seems this key combination is mapped now to this special behavior.

When using the “legacy editor,” insert the <, > works as expected (as it was before.)

Here’s a video recording https://imgur.com/a/7om2Ohf

Obsidian version: v0.13.14
Installer version: v0.12.3
Login status: not logged in
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 1
Safe mode: on

It seems related to the CodeMirror 6 update. I checked the inline demo editor on CodeMirror 6, and I experienced the same behavior.

I dug further, and I noticed that on version 6, the Alt+< and Alt+> is mapped to cursorDocStart and cursorDocEnd CodeMirror 6 Reference Manual

The “Legacy Emacs-style key bindings for macOS” toggle in the Obsidian settings has no effect.

Since the mapping is there by default, does this mean that I have to remove this key binding to support the Hungarian keyboard layout?

If you set this to standard, and restart obsidian, does it work?

Nope. I tried again - restarted the app multiple times with the option enabled and disabled and nothing changed. The “vim mode” also does not change this.

will be fixed 0.13.17

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.