An error occurred while loadin Obsidian. Error: EACCES: permission denied. (windows)

What I’m trying to do

Open a folder not only with md files but with some project files with node_modules.
Specifically with vue file. It’s a pnpm symlinked file.

Things I have tried

I tried adding

{
  "userIgnoreFilters": [
    "node_modules"
  ]
}

but the error comes presumably before it loads the exclusions.

  • No plugins, newest version. Everything works with other folders without node_modules.
  • The permissions are obviously correct and the io errors on windows/node can be very misleading.

Tried to reproduce by

mkdir x
cd x
pnpm init
pnpm i vue

now pnpm created the correct symlink, which looks like a folder in win explorer (compared to broken one which looked as a file).

So the solution is probably to restore/reset pnpm packages/links.

I deleted the offending file and everything/the node app still worked as expected.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.