Alt + d doesn't work as a hotkey

Steps to reproduce

I have Alt + A as toggle left side bar and Alt + D as toggle right side bar.
When I press Alt + D, nothing happens and the mouse just changes to a cross (for Alt select non contiguous text). Any other shortcut that involves Alt + works, but just Alt + D doesn’t work.

Expected result

Pressing Alt + D would execute the shortcut, in this case: Toggle right sidebar.

Actual result



Operating system: Windows 10 Pro 21H1

Debug Info

Obsidian version: v0.14.2
Installer version: v0.12.12
Operating system: Windows 10 Pro 10.0.19043
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: on
Base theme: dark
Community theme: ITS Theme
Snippets enabled: 1
Safe mode: off
Plugins installed: 34
Plugins enabled: 27
1: Sliding Panes (Andy's Mode)
2: Typewriter Scroll
3: Hotkeys++
4: Show Current File Path
5: Periodic Notes
6: Templater
7: Style Settings
8: Find unlinked files and unresolved links
9: Calendar
10: Checklist
11: Kanban
12: Snippets plugin
13: Zoom
14: Workbench
15: Editor Syntax Highlight
16: Metatable
17: Better footnote
18: Outliner
19: Tidy Footnotes
20: Footlinks
21: Footnote Shortcut
22: Hotkeys for templates
23: Pluck
24: MetaEdit
25: Obsidian Git
26: Timelines
27: Quiet Outline

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

  • Alt + D as a hotkey worked fine in a previous version.
  • After deleting Alt+D as a shortcut, when I try assigning Alt + D again, nothing happens, as if I assigned it already.
  • My keyboard is working fine.
  • To my knowledge, Alt + D is not used by any other software. I closed almost all my softwares.
  • I have assigned Alt + G to toggle right side bar. That works fine
  • Thank you for your help

works for me. post a screen recording of this happening in the help vault. Also download and reinstall obsidian.

This is what the issue looked like before. (Mar 23, 2022)

Before demo

Issue is now resolved. (June 18, 2022) Using v0.14.15

Now demo