Allow files to be excluded when you use autocomplete to select a link

Use case or problem

As my vault grows of daily, work, and project-related notes grows, I have more and more notes that begin with the same string, like project or initiative notes that all start with the same client or department name.

When I enter double brackets and start typing a client name, I have ti type more and more characters before the autocomplete will surface the link I need. And many of the autocomplete options are no longer relevant.

Proposed solution

Provide a way to exclude files from appearing in the link auto-complete. Possible ideas:

  • allow YAML tag where you can exclude an individual file from the index
  • add index settings where you can list directories to exclude (could also allow exclusions from search or quick switcher)

Current workaround (optional)

Previously, I removed the files from my vault, but then it was a pain when I needed to reference something.

Related feature requests (optional)

I didn’t see any

4 Likes

I’d love this too. I currently have a massive folder of pdfs that I use to link notes, but would only like any of them to appear in autocomplete if I specifically type their folder ‘docs/’ first, as I reference them less than 1% of the time when I autocomplete.

1 Like

I’d also like to exclude the attachment folders and files from all the indexing which affects Search, Quick Switcher, and Autocomplete.

1 Like

+1. I have a bunch of attachments with long/random filenames and whenever I start to enter a tag, invariably there are dozens of useless attachments popping up in the suggestions box. Logseq and Remnote ignore the attachments and it results in a much cleaner interface.

This was implemented a while back. Settings>Files>excluded files

Oh, awesome! Thanks! Not sure how I missed that.