All folders and files permission suddenly changed

Things I have tried

I searched about obsidian offline mode and files change permission, but still have not found the solution. Need your help urgently.

What I’m trying to do

I am a Linux user. I use Ubuntu. I use the obsidian App Image -0.12.19 version on my Linux computer.

Previously I open this Obsidian in offline mode (no internet connection). I open my last vault, continue my last obsidian notes, doing my work with this obsidian vault.

Then I connect to my internet (this obsidian app image still opened). Nothing happens until I continue my obsidian notes then I notice some warning on my upper right side “…cannot write: access denied” (something like that, I don’t remember exactly).

Then I open my File Manager. And now I see all my folders in my drive (Documents folder, Download, Desktop, etc include all its files) are protected.

I tried to change my folders permission through the terminal:

sudo chmod -r 777 *

to change its permission but still failed. All the folders and files are still protected.

The terminal results are:

chmod: changing permissions of ‘./files_name.js’: Read-only file system

It happens to all files and results.

Now I also can’t open this obsidian app image file and other app image files.

Why it can happen? All files in my drive change to be protected files.

And how to solve it? I haven’t met the solution.

Thank you.


Issue solved.

When you get this situation, try to reboot your Linux Computer, then check the filedisk.

Use safe mode, and run:

‘fsck /dev/{your_drive_location}’

And try to reboot in normal mode.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.